Reduce CSP's overall level of Error Console logging

RESOLVED DUPLICATE of bug 542302

Status

()

defect
RESOLVED DUPLICATE of bug 542302
9 years ago
9 years ago

People

(Reporter: bsterne, Assigned: geekboy)

Tracking

(Blocks 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

For a single load of a page with "allow 'self'" we log 5 lines:

CSP debug: CSP CREATED
CSP debug: CSP POLICY INITED TO 'allow *'
CSP debug: REFINE POLICY: allow 'self'
CSP debug:          SELF: http://mochi.test:8888/tests/content/base/test/file_csp_redirects_page.sjs?testid=control1&csp=1
CSP debug:  in permitsAncestry(), docShell = [xpconnect wrapped nsIDocShell @ 0x4689dd40 (native @ 0x44dadf14)]

Assigning to geekboy for now, but I can probably take this if his plate is full.  Either way, we should sync up on what info really belongs on the Error Console.
Bug 542302 aims to fix this, and also the JS console logging at the same time.  While we should reduce the amount logged, we should make a way for it to come back on for developers testing CSP on their site.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 542302
You need to log in before you can comment on or make changes to this bug.