The CSS text-decoration property is ignored on an input type=submit element (submit button) when ever an html document includes a DOCTYPE declaration of any kind

RESOLVED DUPLICATE of bug 219516

Status

()

Core
CSS Parsing and Computation
--
minor
RESOLVED DUPLICATE of bug 219516
8 years ago
8 years ago

People

(Reporter: nc1943, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 (.NET CLR 3.5.30729)

The CSS text-decoration property is ignored (or behaves as if it is always set to "text-decoration: none") on an input type=submit element (submit button) when ever an html document includes a DOCTYPE declaration of any kind. 

Reading the CSS 2.1 spec for this property (http://www.w3.org/TR/CSS21/text.html#propdef-text-decoration), I don't see a reason it should behave this way (but what do I know).

Reproducible: Always

Steps to Reproduce:
1. Create an html file with the following content (notice it contains a submit button with style text-decoration: underline):

<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" >
	<head>
		<title>css property text-decoration ignored</title>
	</head>
	<body>
		<form method="post" action="." id="myform" name="myform">
			<input type="submit" value="Button Text Should Be Underlined" id="somebtn" name="somebtn" style="text-decoration: underline;" />
		</form>
	</body>
</html>

2. Notice the submit button's text is indeed underlined.

3. Add any valid DOCTYPE declaration to the top of the page (e.g. choose from the list at http://www.w3.org/QA/2002/04/valid-dtd-list.html)

4. Notice the submit button's text is NOT underlined.


Actual Results:  
Without a DOCTYPE declaration at the top of the file the button's text is underlined when you set it's style attribute to "text-decoration: underline;" as expected. However when you add a DOCTYPE declaration the button's text is NOT underlined.

Expected Results:  
I believe submit buttons should be rendered with the text-decoration specified regardless of the of the DOCTYPE declaration.
(Reporter)

Comment 1

8 years ago
Why would you even want the text of a submit button underlined?  Perhaps the style of your website calls for hypertext links instead of buttons to preform various actions but you still want the enter-key capturing feature of a submit button so you style your submit buttons to look like hypertext links.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 219516
You need to log in before you can comment on or make changes to this bug.