Last Comment Bug 560884 - Fix .tv on PSL
: Fix .tv on PSL
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Networking (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Gervase Markham [:gerv]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-21 09:49 PDT by Gervase Markham [:gerv]
Modified: 2010-06-18 12:01 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
.4-fixed
.11-fixed


Attachments
Patch v.1 (454 bytes, patch)
2010-04-23 08:25 PDT, Gervase Markham [:gerv]
no flags Details | Diff | Splinter Review
Patch v.2 (478 bytes, patch)
2010-04-27 04:21 PDT, Gervase Markham [:gerv]
pkasting: review+
dveditz: approval1.9.2.4+
mbeltzner: approval1.9.1.11+
Details | Diff | Splinter Review

Description Gervase Markham [:gerv] 2010-04-21 09:49:26 PDT
We should make .tv flat.

Peter Bowen writes:

The current public suffix list suggests that {com,net,org,gov}.tv are
public suffixes.  However, none of the available documentation supports
this:

http://registrar.verisign-grs.com/whois/whois_tv.html
- Whois data on com.tv shows a single registration
- {net,org,gov}.tv are shown as unregistered

http://com.tv/ is an active website.  It is in Chinese, and is not
translatable using machine tools, as it contains text that has been
rendered into graphics.

Searches using public search engines (Google, etc) do not show any sites
in {net,org,gov}.tv and show results for com.tv that match the pattern
for a private domain rather than public suffix.

Several registrar FAQs on the .tv TLD suggest that it is completely
flat, like the .com TLD.
http://www.webnic.cc/domainwholesale_domainfaq_tv.htm
https://support.exabytes.com/KB/a2501/tv-domain-faqs.aspx
http://www.webserve.ca/domainregistration/ (Differentiates "premium
names", but only notes that they have a different pricing structure)
http://www.nominalia.com/domains/tld/tv.html?chglng=eng (Defines premium
names as having one to three characters as the second level label)

Although it is not necessarily a reliable source,
http://blogs.msdn.com/ieinternals/archive/2009/09/19/Private-Domain-Names-and-Public-Suffixes-in-Internet-Explorer.aspx supports that .tv is completely flat.

I realize that the guidelines state that emails with updates "must come
from an address in your registry's official domain", and I am in no way
related to the .tv registrar, so please feel free to ignore this email.

Thanks,
Peter
Comment 1 Gervase Markham [:gerv] 2010-04-23 08:25:36 PDT
Created attachment 441044 [details] [diff] [review]
Patch v.1

I think the safest thing to do is just remove com.tv. If the others are unregistered, it doesn't matter for now, and if the government of Tuvalu decides to have a web presence, it's very likely to be under gov.tv IMO.

Gerv
Comment 2 Peter Kasting 2010-04-23 10:11:31 PDT
I think the safest thing to do is to remove everything but .tv.  If .tv is flat, and anyone ever sets up gov.tv or net.tv, Chrome users won't be able to easily visit those sites.  I read some of the verisign.tv docs and they don't mention anything about 2LDs (although to be fair they don't mention much of anything).
Comment 3 Gervase Markham [:gerv] 2010-04-27 04:21:48 PDT
Created attachment 441761 [details] [diff] [review]
Patch v.2

OK, then.

Gerv
Comment 4 Peter Kasting 2010-04-27 11:46:09 PDT
Comment on attachment 441761 [details] [diff] [review]
Patch v.2

You might want a brief comment about not listing any 2LDs as "reserved" since none seem to exist (since the Wikipedia entry noted in the existing comment mentions gov.tv in passing).
Comment 5 Gervase Markham [:gerv] 2010-04-28 03:29:06 PDT
http://hg.mozilla.org/mozilla-central/rev/d0e8385ca752

Gerv
Comment 6 Mike Beltzner [:beltzner, not reading bugmail] 2010-05-25 12:44:11 PDT
Comment on attachment 441761 [details] [diff] [review]
Patch v.2

a=beltzner for mozilla-1.9.1 (default) and mozilla-1.9.2 (default)
Comment 8 christian 2010-06-10 16:25:56 PDT
This was approved for GECKO1924_20100413_RELBRANCH on mozilla-1.9.2 as well, so that we can pick the fix up if we do build #7.

Note You need to log in before you can comment on or make changes to this bug.