Problem on upgrade from an folder named "archives" already exists

RESOLVED DUPLICATE of bug 104525

Status

--
major
RESOLVED DUPLICATE of bug 104525
9 years ago
2 years ago

People

(Reporter: patrice.pillot, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/4.3; Linux) KHTML/4.3.4 (like Gecko)
Build Identifier: Icedove/3.0.4

Hi,

I've had a look at the bug list but didn't find something similar albeit bugs 557030 and 529788 confirmed to me what I understood from the problems I report here.

I just upgraded from Thunderbird 2.0.0 to 3.0.4 on my Debian box (with Thunderbird rebranded as Icedove).

In one on my (POP) account, before the upgrade, I had one folder named ARCHIVES (i.e. a matching ARCHIVES{,.msf,.sbd} triad) in the top folder of this account (i.e. in the same level as Inbox, Trash, ...). 

It turns out that with the new "Archives" feature introduced in version 3, this folder became hidden by the Archives () triad created during the migration process when I launched version 3 for the first time. This was quite frustrating since as its name implies, this is the folder where all of my archives are stored. Fortunately, thanks to the special icon and of the different capitalization, I was able to guess some conflict happened and I solved the problem by manually renaming ARCHIVES{,.msf,.sbd} to POOL{,.msf,.sbd} (but now I'm stuck with the needless "Archives" folder as described in 529788 ;-).



Reproducible: Always

Steps to Reproduce:
1. With thunderbird < 3.0, let's say 2.0.0, create a new account
2. Add to this account a folder names "Archives" at the same level as Inbox, Trash, ...
3. Move some mails in this folder
4. Stop Thunderbird 2.0.0
5. Run Thunderbird 3.0.4 (this should be OK with any version >= 3.0)

Actual Results:  
The folder created at step 2 is hidden with the "automatic" new Archives folder.

Expected Results:  
There should have been a warning shown to me saying there was a name clash and an assistant of some sort should have helped me to choose a new name and updated all of my filters.

I tag this bug as major even though there is no real data loss but:
1. "Archives" happens to be a rather natural and not so uncommon name to store one's archives.
2. I don't think an unexperimented user would have recovered from it easily.
(In reply to comment #0)
> User-Agent: (snip) Konqueror/4.3; Linux)
> In one on my (POP) account, before the upgrade, I had one folder named ARCHIVES
> It turns out that with the new "Archives" feature introduced in version 3,
> this folder became hidden by the Archives.

As you use Linux, file system is case sensitive, so both files of ARCHIVES and Archives can exist at same time. AFAIK, Thunderbird doesn't support folders of different cases at same time. Although Tb can distinguish file names of different cases, Tb has case-insensitive comparisons in many places.
Same issue can occur on sent, Sent, SENT for sent folder of Tb, and I think there is no differene from "sent/Sent/SENT" issue.

Tb's archives folder can be set to any folder except for some special IMAP servers. Work around is: Create a folder, set is as "archives folder" of Tb, deleted file of Archives/Archives.msf created by Tb.  

> Expected Results:  
> There should have been a warning shown to me saying there was a name clash
> and an assistant of some sort should have helped me to choose a new name
> and updated all of my filters.

Reasonable request. I think "Silently ignoring or hiding" is not so kind behaviour for users.

FYI.
Bug 484329 is same problem on folder of ordinal IMAP server with case-sensitive file system. In IMAP case, Tb probably uses ARCHIVES as archives folder of Tb by fix of Bug 484329.

Updated

8 years ago
Component: General → Backend
Product: Thunderbird → MailNews Core
QA Contact: general → backend

Comment 2

7 years ago
(confirming) I'm assuming this hasn't been fixed - i don't recall seeing such a bug report
Status: UNCONFIRMED → NEW
Ever confirmed: true
Tb was case sensitive in IMAP Mbox name processing.
- Yahoo IMAP is case sensitive in Mbox name, so ARCHIVES, Archives, archives,
  ... can be created.
- MS Win's file system is case insensitive, although file name is held
  with keeping case. So, Tb adds suffix to file name of .msf file.
  create Archives   => Archives.msf    Archives.sbd   
  create archives   => archives-1.msf  archives-1.sbd
  create ARCHIVES   => ARCHIVES-2.msf  ARCHIVES-2.sbd
  create aRchives-1 => aRchives-1-1.msf
  create arChives-1 => arChives-1-2.msf
  create arcHives-1 => arcHives-1-3.msf
  Note:
  Because order in LIST command response is ARCHIVES, Archives, archives,
  mismatch in case probably happens if parent folder is renamed.
    ARCHIVES=>Archives.msf, Archives=>archives-1.msf, archives=>ARCHIVES-2.msf
Tb is perhaps not compatible with case sensitive local file system in processing mail box folder file name.

Creation of file is case sensitive, but comparison of file name is case insenstive in order to support MS Win's case insensitive file system, thus Archives.msf file is hidden when ARCHIVES.msf exists in case sensitive file system of Linux.

Comment 4

3 years ago
duplicate of bug 104525?

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 104525
You need to log in before you can comment on or make changes to this bug.