Closed Bug 561726 Opened 10 years ago Closed 10 years ago

animateTransform does not work on gradientTransform

Categories

(Core :: SVG, defect)

x86
All
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: marek.raida, Assigned: longsonr)

References

()

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a5pre) Gecko/20100415 Minefield/3.7a5pre (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a5pre) Gecko/20100415 Minefield/3.7a5pre (.NET CLR 3.5.30729)

animateTransform element is supposed to work with different transform attributes. In majority cases it is just attributeName="gradient" and it works fine, however it should work also with attributeName="gradientTransform" but it is not

Reproducible: Always

Steps to Reproduce:
1. create some gradient
2. add animateTransform element with attributeName="gradientTransform", rotate for example...
3. apply animateTransform to gradient
Actual Results:  
animation won't start

Expected Results:  
animation should be working
Attached image testcase
this one is working in presto but is not in gecko
when fixing consider patternTransform too.
(In reply to comment #2)
> when fixing consider patternTransform too.
Yup -- that is, every attribute with type "%TransformList;" on http://www.w3.org/TR/SVG11/attindex.html
(which is: { transform, gradientTransform, patternTransform })
Assignee: nobody → longsonr
Includes lazy creation of gradient and pattern transforms so that if you don't use them you don't pay for them.
Attachment #442921 - Flags: review?(jwatt)
nsSVGPatternFrame::GetPatternTransform should probaly have static const gfxMatrix identityMatrix; rather than gfxMatrix matrix but I'll make that change on check in if that's all right.
Comment on attachment 442921 [details] [diff] [review]
patch with reftests

r=jwatt

Sorry for the delay.

(In reply to comment #6)
> nsSVGPatternFrame::GetPatternTransform should probaly have static const
> gfxMatrix identityMatrix; rather than gfxMatrix matrix but I'll make that
> change on check in if that's all right.

Fine by me.
Attachment #442921 - Flags: review?(jwatt) → review+
pushed http://hg.mozilla.org/mozilla-central/rev/b307f4eb573b

and then http://hg.mozilla.org/mozilla-central/rev/381d95a8f5ba because one of the new reftests this patch adds fails on macs.

Daniel, Brian. You have macs, any idea why the new gradient reftest fails there?
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
(In reply to comment #8)
> Daniel, Brian. You have macs, any idea why the new gradient reftest fails
> there?

Sorry, my mac is running XP.
It fails on my mac, too, but it's not animation-related -- I get the same behavior (strip of slightly-darker green on the left edge) if I just apply the gradientTransform attribute up-front.  I'll file a bug on it.
You need to log in before you can comment on or make changes to this bug.