Closed Bug 561870 Opened 10 years ago Closed 10 years ago

Enforce min/max limits on viewport values

Categories

(Firefox for Android Graveyard :: General, defect)

Fennec 1.1
x86
Windows 7
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: martijn.martijn, Assigned: mbrubeck)

References

()

Details

(Keywords: testcase)

Attachments

(1 file)

I can see this on Fennec on windows as well as on the n900. Using the 1.92 branch from 2010-04-26.

The tab preview of https://bugzilla.mozilla.org/attachment.cgi?id=440871 shows up black, while the testcase certainly isn't black.

I'm seeing this error in the error console, when that happens:
uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIDOMCanvasRenderingContext2D.drawWindow]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://browser/content/tabs.xml :: updateThumbnail :: line 61"  data: no]
Assignee: nobody → mbrubeck
I can't reproduce this in a 1.1b1 candidate build on N900 or in current trunk builds on Linux desktop, though I did see Fennec freeze after opening the testcase in an older 1.9.2 Linux desktop build.

The testcase sets viewport width=9999999999999.  According to this page, the iPhone limits viewport width to 10000px.  We should probably do the same.
http://developer.apple.com/safari/library/documentation/AppleApplications/Reference/SafariHTMLRef/Articles/MetaTags.html
Add checks for the other limits too: height and the scales
Attached patch patchSplinter Review
Here's a patch and test case.

I don't know if it fixes the original problem since I haven't managed to reproduce it yet.  I'll try a mobile-1.1 build....
Attachment #442238 - Flags: review?(mark.finkle)
Attachment #442238 - Flags: review?(mark.finkle) → review+
Summary: Tab preview of testcases of bug 561203 shows up black, getting uncaught exception (NS_ERROR_FAILURE) [nsIDOMCanvasRenderingContext2D.drawWindow] → Enforce min/max limits on viewport values
Depends on: 561815
it seems to fix the problem I saw

pushed:
http://hg.mozilla.org/mobile-browser/rev/0a0598e61477
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
verified FIXED on builds:

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2.5pre) Gecko/20100430 Namoroka/3.6.5pre Fennec/1.1b2pre

and

Mozilla/5.0 (X11; U; Linux armv71; Nokia N900; en-US; rv:1.9.3a5pre) Gecko/20100430 Namoroka/3.7a5pre Fennec/1.1b2pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.