If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mutualy blocking modal dialogues. Save + Javascript unresponsiveness.

RESOLVED DUPLICATE of bug 476541

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 476541
8 years ago
8 years ago

People

(Reporter: Shayne O'Neill, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

When a Save dialogue is opened, if the Website tries to open another modal dialogue, the two dialogues block each others operation.

Because the Save dialogue blocks access to the firefox alerts, the firefox alert can not be dismissed. Likewise the firefox alert blocks the save dialogues ability to be dismissed.

A force-quit is required to leave this state

Reproducible: Always

Steps to Reproduce:
1. Open a web page with javascript that produces an excessive load.
2. Open a save dialogue (Ie save page)
3. Wait till the Javascript interpreter offers to kill the script
Actual Results:  
As described.

The "Stop all scripts" dialogue can not be clicked, and the Save dialogue appears to be blocked.

Expected Results:  
Intuitively the save dialogue should still work, or the "excessive load" dialogue should still work, or both.

This appears to be related to the following bug:

https://bugzilla.mozilla.org/show_bug.cgi?id=523940

The bug referenced would perhaps be easier to reproduce.

Please not that an inability to save might be dangerous on something like a financial site.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 476541
You need to log in before you can comment on or make changes to this bug.