Last Comment Bug 562073 - implement box-lines property from css3-flexbox
: implement box-lines property from css3-flexbox
Status: RESOLVED DUPLICATE of bug 702508
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: unspecified
: x86 Windows Server 2003
: -- normal with 6 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-27 10:11 PDT by Giorgio
Modified: 2012-11-08 08:48 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Testcase adapted from corresponding webkit bug (603 bytes, text/html)
2011-03-01 02:30 PST, Marc Diethelm
no flags Details

Description Giorgio 2010-04-27 10:11:09 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.3a5pre) Gecko/20100426 Minefield/3.7a5pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.3a5pre) Gecko/20100426 Minefield/3.7a5pre

hi

http://www.w3.org/TR/css3-flexbox/#propdef-box-lines

parity webkit (-webkit-box-lines)

Reproducible: Always
Comment 1 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2010-04-27 12:32:18 PDT
We're probably going to want to reimplement flexbox as it gets standardized; I don't see this happening before we do that.
Comment 2 Marc Diethelm 2011-03-01 02:30:50 PST
Created attachment 515871 [details]
Testcase adapted from corresponding webkit bug

The testcase uses an imaginary experimental property -moz-box-lines.

I realize Bugzilla is not the place to evangelize. However seeing that things like rounded corners and shadows, though also experimental, are widely implemented I think it's fair to say that "CSS3 Flexboxes" have not gotten the attention it warrants,  even though its significance can hardly be overstated. That is, if you're a web developer who's has had to put up with  the madness of hacking up layouts with floats and absolute positioning! In order to build non-super-trivial layouts sanely, quickly and easily flexboxes are the way to go!

Box-lines: multiple is the missing piece, because it's absence breaks usability (think small screens).

Flexie a JS polyfill that makes flexboxes usable across browsers today, which for me presents nothing less than a revolution in the way I code web layouts.

As a frontend web dev I'll argue that Flexboxes are the most important module of CSS3! Thanks, and I hope you'll excuse may non-implementation oriented comment...
Comment 3 Zéfling 2011-10-28 14:49:25 PDT
This bug is invalid with the new css3-flexbox draft.
Comment 4 Minh Nguyễn 2012-10-20 14:37:01 PDT
The new draft has "flex-wrap: wrap", which corresponds to the old "box-lines: multiple". Firefox 18 with layout.css.flexbox.enabled set doesn't seem to recognize the "-moz-flex-wrap" property at all.
Comment 5 Daniel Holbert [:dholbert] 2012-11-08 08:48:19 PST

*** This bug has been marked as a duplicate of bug 702508 ***

Note You need to log in before you can comment on or make changes to this bug.