text/html treeitem in Helper App panel is broken (NS_NOINTERFACE)

VERIFIED FIXED in mozilla0.8

Status

P3
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: jrgmorrison, Assigned: paulkchen)

Tracking

Trunk
mozilla0.8

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Do Edit->Preferences, then select the Navigator->Helper Applications
panel (pref-applications.xul).

Then mousedown on the 'text/html' entry in the tree -- this JS error
is thrown:

JavaScript error:
 line 4: uncaught exception: [Exception... "Component returned failure code:
0x80004002 (NS_NOINTERFACE) [nsISupports.QueryInterface]"
nsresult: "0x80004002 (NS_NOINTERFACE)"
location: "JS frame :: chrome://communicator/content/pref/overrideHandler.js
:: anonymous :: line 103"  data: no]

The same error also occurs when you press the 'Edit...' button while this
treeitem is selected, and the Edit panel comes up blank.

chrome://communicator/content/pref/overrideHandler.js

 98 if (extensionTargets) {
 99 extensionTargets =
extensionTargets.QueryInterface(Components.interfaces.nsISimpleEnumerator);
100 while (extensionTargets.hasMoreElements()) {
101 var currentExtension = extensionTargets.getNext();
102 if (currentExtension) {
103 currentExtension =
currentExtension.QueryInterface(Components.interfaces.nsIRDFLiteral);
104 extString += currentExtension.Value.toUpperCase() + " ";
105 }

Again, Ben says "not good". Details?
(Reporter)

Updated

18 years ago
Keywords: rtm

Comment 1

18 years ago
Minus.  I don't think most users will try to edit it.
Whiteboard: [rtm-]
QA Contact: sairuh → shrir

Comment 2

18 years ago
Given that flaky and broken helper app controls were one of the most prominent  
complaints of 6.0, beta1 really shouldn't ship without this.
Keywords: rtm → nsbeta1
Whiteboard: [rtm-]
(Assignee)

Comment 3

18 years ago
nav triage team:

Actually, this thing shouldn't be editable, reassigning to pchen, setting
mozilla0.8 target milestone
Assignee: ben → pchen
Target Milestone: --- → mozilla0.8

Comment 4

18 years ago
We're past time to cut these low priority bugs from mozilla0.8.  Please update
these bugs today. 
(Assignee)

Comment 5

18 years ago
Ok, so the problem is that the prepopulated mimeTypes.rdf in
mozilla/profile/defaults/ doesn't jive with what the helper apps prefs code is
looking for. Fix is to remove about attributes from NC:fileExtensions tags. This
prevents the exception in overrideHandler.js:103, and this is the form it spits
out back to . Since the exception doesn't get thrown, the code that determines
if the mapping is editable or not gets executed.
(Assignee)

Comment 6

18 years ago
Created attachment 24513 [details] [diff] [review]
remove 'about' attributes from <NC:fileExtensions>

Comment 7

18 years ago
sr=mscott

Comment 8

18 years ago
r=blake
(Assignee)

Comment 9

18 years ago
Fix checked in. Unfortunately, this fixes new profiles only. Other way to fix is
to remove those attributes from your mimeTypes.rdf file in your profile folder.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Updated

18 years ago
Blocks: 64406

Comment 10

18 years ago
don't see the js error anymore. A Warning "prev sibling is not in or list" 
appers in the console. Hope that does not matter..
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.