Using a system proxy ignores socks_remote_dns pref

RESOLVED FIXED in mozilla11

Status

()

Core
Networking
RESOLVED FIXED
7 years ago
2 months ago

People

(Reporter: mattwoodrow, Assigned: mattwoodrow)

Tracking

unspecified
mozilla11
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

7 years ago
It looks like nsProtocolProxyService::Resolve_Internal never checks the value of mSOCKSProxyRemoteDNS when setting up a proxy.
(Assignee)

Comment 1

7 years ago
Created attachment 442040 [details] [diff] [review]
Fix

Tested this and it works fine. Not sure who to ask for a review on this.
(Assignee)

Updated

7 years ago
Attachment #442040 - Flags: review?(bzbarsky)
(Assignee)

Updated

7 years ago
Component: Preferences → Networking
Product: Firefox → Core
QA Contact: preferences → networking
Attachment #442040 - Flags: review?(bzbarsky) → review?(jduell.mcbugs)
Er, I meant to say:

I don't really know this code.  Jason, do you?  Or do we need to get Christian or Honza to look at this?
Comment on attachment 442040 [details] [diff] [review]
Fix

I don't know SOCKS at all.  Biesi, this is a one-liner--can you look?
Attachment #442040 - Flags: review?(jduell.mcbugs) → review?(cbiesinger)
So... there is some discussion about this in https://bugzilla.mozilla.org/show_bug.cgi?id=134105#c53 and several following comments.
Comment on attachment 442040 [details] [diff] [review]
Fix

but I think this patch is a good idea.
Attachment #442040 - Flags: review?(cbiesinger) → review+
Assignee: nobody → matt.woodrow
Keywords: checkin-needed
http://hg.mozilla.org/integration/mozilla-inbound/rev/6bbb0b61173d
Keywords: checkin-needed
OS: Mac OS X → All
Hardware: x86 → All
Target Milestone: --- → mozilla11

Comment 7

6 years ago
https://hg.mozilla.org/mozilla-central/rev/6bbb0b61173d
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Duplicate of this bug: 474824
You need to log in before you can comment on or make changes to this bug.