test_sibling-matching-parent.html and test_bug270414.html fail intermittently due to xpcWaitForFinishedFrames in NavigationUtils.js assuming that data: URLs are parsed synchronously

RESOLVED FIXED in mozilla1.9.3a5

Status

()

defect
RESOLVED FIXED
9 years ago
7 years ago

People

(Reporter: hsivonen, Assigned: hsivonen)

Tracking

({intermittent-failure})

Trunk
mozilla1.9.3a5
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(1 attachment)

After enabling the HTML5 parser on the real tinderbox, test_sibling-matching-parent.html fails intermittently due to NavigationUtils.js accessing document.body without a null check.

This didn't show up on the tryserver. The test passes if document.body exists by the time the script tries to access it and fails if the body element hasn't yet been inserted into the DOM by the parser.
Blocks: 438871
Whiteboard: [orange]
Also:
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272463095.1272464622.8870.gz
185 INFO TEST-PASS | /tests/docshell/test/navigation/test_bug270414.html |
Should be able to navigate on-domain opener's children by setting location.
186 INFO TEST-PASS | /tests/docshell/test/navigation/test_bug270414.html |
Should be able to navigate on-domain opener's children by calling window.open.
187 INFO TEST-PASS | /tests/docshell/test/navigation/test_bug270414.html |
Should be able to navigate on-domain opener's children by submitting form.
188 ERROR TEST-UNEXPECTED-FAIL |
/tests/docshell/test/navigation/test_bug270414.html | Should be able to
navigate on-domain opener's children by targeted hyperlink. - got TypeError:
wnd.document.body is null, expected "This frame was navigated."
Summary: test_sibling-matching-parent.html fails intermittently due to NavigationUtils.js accessing document.body without a null check → test_sibling-matching-parent.html and test_bug270414.html fail intermittently due to NavigationUtils.js accessing document.body without a null check
The problem is that xpcWaitForFinishedFrames doesn't really wait for the frames to finish but waits for their window.location to become the target (data:) URL.
Summary: test_sibling-matching-parent.html and test_bug270414.html fail intermittently due to NavigationUtils.js accessing document.body without a null check → test_sibling-matching-parent.html and test_bug270414.html fail intermittently due to xpcWaitForFinishedFrames in NavigationUtils.js assuming that data: URLs are parsed synchronously
Posted patch Potential fixSplinter Review
Needs a couple of tryserver runs still.
Assignee: nobody → hsivonen
Status: NEW → ASSIGNED
Comment on attachment 442352 [details] [diff] [review]
Potential fix

The tryserver isn't cooperating, so requesting review based on local testing only.
Attachment #442352 - Flags: review?(bzbarsky)
Comment on attachment 442352 [details] [diff] [review]
Potential fix

r=bzbarsky
Attachment #442352 - Flags: review?(bzbarsky) → review+
http://hg.mozilla.org/mozilla-central/rev/64488a668662
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Flags: in-testsuite+
Target Milestone: --- → mozilla1.9.3a5
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.