If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

jsreftest randomly fails with "timed out waiting for onload to fire" in DOM worker tests

RESOLVED WONTFIX

Status

()

Core
DOM
RESOLVED WONTFIX
8 years ago
5 years ago

People

(Reporter: hsivonen, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
After the HTML5 parser enablement JS reftest started failing in a way that looks random with "timed out waiting for onload to fire".

My guess is that something in the harness (that I fail to see right away) checks a condition and either document.writes directly (which is fine) or if the condition is not ready posts a timeout and calls document.write() from there (not fine, blows away the document so that onload never fires).
bclary, can you maybe help Henri out here?
What were examples of specific tests that were timing out?
(Reporter)

Comment 3

8 years ago
Calling document.write from an event handler (e.g. window.onerror) is bad, too.
(Reporter)

Comment 4

8 years ago
(In reply to comment #2)
> What were examples of specific tests that were timing out?

worker-error-propagation.js (four times)
worker-init.js (twice)
worker-terminate.js (twice)

Sometimes automation.py complained about no output but not always. Once the harness crashed. http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272463752.1272466100.13523.gz
Three pushes with it enabled:

Windows had five greens plus

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272461736.1272465659.12204.gz
REFTEST TEST-UNEXPECTED-FAIL | file:///e:/builds/moz2_slave/mozilla-central-win32-debug-unittest-jsreftest/build/jsreftest/tests/jsreftest.html?test=js1_8_5/extensions/worker-init.js | timed out waiting for onload to fire

Mac had five greens

Linux (where we're running on two refplatforms) had seven greens plus

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272456733.1272464129.6846.gz
REFTEST TEST-UNEXPECTED-FAIL | file:///builds/slave/mozilla-central-linux-debug-unittest-jsreftest/build/jsreftest/tests/jsreftest.html?test=js1_8_5/extensions/worker-error-propagation.js | timed out waiting for onload to fire
REFTEST TEST-UNEXPECTED-FAIL | file:///builds/slave/mozilla-central-linux-debug-unittest-jsreftest/build/jsreftest/tests/jsreftest.html?test=js1_8_5/extensions/worker-terminate.js | timed out waiting for onload to fire

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272457501.1272459807.22658.gz
REFTEST TEST-UNEXPECTED-FAIL | file:///home/cltbld/talos-slave/mozilla-central-fedora-debug-u-jsreftest/build/jsreftest/tests/jsreftest.html?test=js1_8_5/extensions/worker-terminate.js | timed out waiting for onload to fire

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272461424.1272462752.1746.gz
REFTEST TEST-UNEXPECTED-FAIL | file:///home/cltbld/talos-slave/mozilla-central-fedora-opt-u-jsreftest/build/jsreftest/tests/jsreftest.html?test=js1_8_5/extensions/worker-error-propagation.js | timed out waiting for onload to fire

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272460239.1272467562.17916.gz
REFTEST TEST-UNEXPECTED-FAIL | file:///builds/slave/mozilla-central-linux-debug-unittest-jsreftest/build/jsreftest/tests/jsreftest.html?test=js1_8_5/extensions/worker-error-propagation.js | timed out waiting for onload to fire
REFTEST TEST-UNEXPECTED-FAIL | file:///builds/slave/mozilla-central-linux-debug-unittest-jsreftest/build/jsreftest/tests/jsreftest.html?test=js1_8_5/extensions/worker-simple.js | timed out waiting for onload to fire

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272462842.1272464461.8340.gz
REFTEST TEST-UNEXPECTED-FAIL | file:///home/cltbld/talos-slave/mozilla-central-fedora-opt-u-jsreftest/build/jsreftest/tests/jsreftest.html?test=js1_8_5/extensions/worker-error-propagation.js | timed out waiting for onload to fire

Linux64 only managed four runs, all orange:

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272458526.1272459807.22660.gz
REFTEST TEST-UNEXPECTED-FAIL | file:///home/cltbld/talos-slave/mozilla-central-fedora64-opt-u-jsreftest/build/jsreftest/tests/jsreftest.html?test=js1_8_5/extensions/worker-error-propagation.js | timed out waiting for onload to fire

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272459968.1272462267.31664.gz
REFTEST TEST-UNEXPECTED-FAIL | file:///home/cltbld/talos-slave/mozilla-central-fedora64-debug-u-jsreftest/build/jsreftest/tests/jsreftest.html?test=js1_8_5/extensions/worker-init.js | timed out waiting for onload to fire

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272465423.1272466874.15871.gz
REFTEST TEST-UNEXPECTED-FAIL | file:///home/cltbld/talos-slave/mozilla-central-fedora64-opt-u-jsreftest/build/jsreftest/tests/jsreftest.html?test=js1_8_5/extensions/worker-error-propagation.js | timed out waiting for onload to fire

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272463752.1272466100.13523.gz
(a bug 559957 without getting around to timing out)

Comment 6

8 years ago
jorendorff: looks like worker-init.js worker-error-propagation.js worker-terminate.js worker-simple.js have the same problem as worker-fib.js in bug 559954.

Can you disable them in the browser as well for now?
OK, I disabled them:
http://hg.mozilla.org/mozilla-central/rev/6c1ba4ef0776

I wasn't able to reproduce the jsreftest hang earlier, but now that we know the HTML5 parser triggers the bug reliably (due to different timing or whatever) I will try it again.
Component: Reftest → DOM: Other
Product: Testing → Core
QA Contact: reftest → general
Summary: jsreftest.html randomly fails with "timed out waiting for onload to fire" → jsreftest randomly fails with "timed out waiting for onload to fire" in DOM worker tests

Comment 8

8 years ago
Were these tests re-enabled? this looks quite similar:


Rev3 Fedora 12x64 mozilla-central opt test jsreftest [testfailed] Started 07:55, finished 08:22, took 28mins

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1274194554.1274196115.24421.gz&fulltext=1

Comment 9

5 years ago
No longer in the tree
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

5 years ago
Keywords: intermittent-failure
(Assignee)

Updated

5 years ago
Whiteboard: [orange]
(Assignee)

Updated

5 years ago
Component: DOM: Other → DOM
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.