Timeout after browser_bug537449.js | must wait for focus

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: mats, Unassigned)

Tracking

({intermittent-failure})

Trunk
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
Timeout from or after browser_bug537449.js with browser-test.js | Waiting for window activation 

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272478884.1272480580.28004.gz
Linux mozilla-central debug test mochitest-other on 2010/04/28 11:21:24

###!!! ASSERTION: Oops!  You're asking for a weak reference to an object that doesn't support that.: 'factoryPtr', file nsWeakReference.cpp, line 109
...
TEST-INFO | chrome://mochikit/content/browser/toolkit/components/startup/tests/browser/browser_bug537449.js | Console message: [JavaScript Error: "[Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIObserverService.removeObserver]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://browser/content/browser.js :: FullZoom_destroy :: line 168"  data: no]" {file: "chrome://browser/content/browser.js" line: 3725}]
...
###!!! ASSERTION: Uh, IsInModalState() called w/o a reachable top window?: 'Error', file /builds/slave/mozilla-central-linux-debug/build/dom/base/nsGlobalWindow.cpp, line 5960
...
TEST-INFO | checking window state
TEST-INFO | (browser-test.js) | Waiting for window activation...
...
TEST-UNEXPECTED-FAIL | automation.py | application timed out after 330 seconds with no output
(Reporter)

Comment 2

9 years ago
See also bug 549893 about the assertions.
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272531346.1272532418.15579.gz
Linux mozilla-central opt test mochitest-other on 2010/04/29 01:55:46
Duplicate of this bug: 562121
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1273034501.1273038085.18146.gz
Linux mozilla-central debug test mochitest-other on 2010/05/04 21:41:41  


Since we seem to be recording minidumps for hangs now, we have stacks for all threads.
(Reporter)

Comment 8

9 years ago
dbaron, where can I find the minidumps?
I don't know that it's particularly useful, but here it is, excerpted from the URL in comment 7.

Comment 10

9 years ago
This should be fixed my patch in bug 543278.

Please reopen if you see this on trunk from this point on.
Assignee: nobody → ehsan
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Depends on: 543278
Resolution: --- → FIXED
Whiteboard: [orange] → [orange][fixed by bug 543278]
Flags: in-testsuite-
Whiteboard: [orange][fixed by bug 543278] → [fixed by bug 543278] [orange]
Target Milestone: --- → mozilla1.9.3a5

Comment 11

9 years ago
I'm out of ideas here.  We probably need someone who knows about the internals of the focus code and how it works on Linux to help here.
Assignee: ehsan → nobody
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Flags: in-testsuite-
Summary: Timeout from or after browser_bug537449.js with browser-test.js | Waiting for window activation → Timeout after browser_bug537449.js | must wait for focus
Whiteboard: [fixed by bug 543278] [orange] → [orange]
Target Milestone: mozilla1.9.3a5 → ---
Comment hidden (Legacy TBPL/Treeherder Robot)
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago7 years ago
Resolution: --- → WORKSFORME
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.