Template Hooks cannot be utilized without code (Extension.pm/Config.pm) extensions existing

RESOLVED FIXED in Bugzilla 3.6

Status

()

Bugzilla
Extensions
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Nicholas Herring, Assigned: Max Kanat-Alexander)

Tracking

Bugzilla 3.6
Bug Flags:
approval +
blocking3.6.1 +

Details

Attachments

(1 attachment)

v1
679 bytes, patch
Max Kanat-Alexander
: review+
Details | Diff | Splinter Review
(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/532.5 (KHTML, like Gecko) Chrome/4.1.249.1064 Safari/532.5
Build Identifier: 3.6

I tried to extend a template using the comments-aftercomments hook with the following location:

extensions/TestMe/template/en/default/hook/bug/comments-aftercomments.html.tmpl

This would not work unless I used extensions/create.pl

Reproducible: Always

Steps to Reproduce:
Within bugzilla root:

1.mkdir -p extensions/TestMe/template/en/default/hook/bug/
2.nano extensions/TestMe/template/en/default/hook/bug/comments-aftercomments.html.tmpl
3.enter <h1>Test Me</h1>
4.Save
5.run checksetup.pl
Actual Results:  
No effect.

Expected Results:  
Heading 1 text after bug comments with the words "Test Me"

This will work if I copy the same file into the template folder of an extension created using extension/create.pl

I am assuming it is intended to allow creation of template hook files without the need for any special setup.
(Reporter)

Updated

7 years ago
Version: unspecified → 3.6
(Assignee)

Updated

7 years ago
Severity: minor → normal
OS: Linux → All
Hardware: x86 → All
Summary: Template Hooks cannot be utilized without extensions/create.pl → Template Hooks cannot be utilized without code (Extension.pm/Config.pm) extensions existing
Target Milestone: --- → Bugzilla 3.6
(Assignee)

Updated

7 years ago
Flags: blocking3.6.1+
(Assignee)

Updated

7 years ago
Assignee: extensions → mkanat
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 1

7 years ago
Created attachment 442304 [details] [diff] [review]
v1

Okay, this fixes it.
Attachment #442304 - Flags: review+
(Assignee)

Updated

7 years ago
Flags: approval+
(Assignee)

Comment 2

7 years ago
Committing to: bzr+ssh://bzr.mozilla.org/bugzilla/trunk/
modified Bugzilla/Install/Util.pm
Committed revision 7146.

Committing to: bzr+ssh://bzr.mozilla.org/bugzilla/3.6/
modified Bugzilla/Install/Util.pm
Committed revision 7092.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.