Last Comment Bug 562730 - Reproducing Mp3 files with html5
: Reproducing Mp3 files with html5
Status: RESOLVED WONTFIX
:
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: unspecified
: x86 All
: -- enhancement with 3 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 662045 (view as bug list)
Depends on:
Blocks: AreWePlayingYet
  Show dependency treegraph
 
Reported: 2010-04-29 12:24 PDT by Andrea Stagi
Modified: 2011-11-06 19:24 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Andrea Stagi 2010-04-29 12:24:40 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US) AppleWebKit/533.2 (KHTML, like Gecko) Chrome/5.0.342.9 Safari/533.2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.9) Gecko/20100401 Ubuntu/9.10 (karmic) Firefox/3.5.9

When I use html5 audio tag for reproducing mp3 files, it doesn't sound. Tag audio on Firefox should support mp3 format.

Reproducible: Always

Steps to Reproduce:
1.Reproduce any mp3 file using tag audio
2.
3.
Comment 1 Robert Longson 2010-04-30 03:09:15 PDT
MP3 seems to be licence encumbered (http://en.wikipedia.org/wiki/MP3#Licensing_and_patent_issues) so an implementation would seem ruled out for the same reasons that h264 is ruled out (http://weblogs.mozillazine.org/roc/archives/2010/01/h264_licensing.html).
Comment 2 Andrea Stagi 2010-04-30 14:25:30 PDT
I see, Chrome and Safari support MP3 cause Google and Apple are in the list of licensees: http://www.mpegla.com/main/programs/AVC/Pages/Licensees.aspx. My problem arose trying to concatenate some audio files by a php script and play the resultant file using an audio tag. MP3 are simply to concatenate, instead of OGG format. Concatenating wave file is as simple as MP3, but the final file is too big. What other file types are supported by audio tag on Firefox?
Comment 3 Matthias Versen [:Matti] 2010-04-30 16:35:31 PDT
>What other file types are supported by audio tag on Firefox?
ogg and wav
Comment 4 Andrea Stagi 2010-05-02 19:15:11 PDT
Ok, thanks..But Mozilla isn't going to acquire Mp3 licence, is it? Or it's thinking about? I think that not supporting a popular format as Mp3 is would be a serious restriction...
Comment 5 Andrea Stagi 2010-05-06 15:26:51 PDT
Hi,

I've discover another tag named "embed". I would report an alternative method for playing mp3 in Firefox using dynamic html:

HTML code

<span id=player></span>
<form>
<input type="button" value="Play my song" onClick="Play('Panama.mp3')">
</form>

Javascript code

function Play(url) {
  document.getElementById("player").innerHTML=
    "<embed src='"+url+"' hidden=true autostart=true height=0 width=0 loop=false>";
}

Setting height and width parameters to 0 it's possible to hide the player.
Comment 6 generalmkii 2010-10-04 14:15:42 PDT
If mp3 is not possible then support for .aac should be considered.
Comment 7 Matthew Gregan [:kinetik] 2010-10-13 20:02:27 PDT
We won't support MP3 for the same reasons we won't support H.264.  See bug 541286 for further details.
Comment 8 :Ms2ger 2011-06-04 05:37:49 PDT
*** Bug 662045 has been marked as a duplicate of this bug. ***
Comment 9 Boris Zbarsky [:bz] (Out June 25-July 6) 2011-06-06 12:03:42 PDT
*** Bug 662045 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.