Closed Bug 562862 Opened 14 years ago Closed 14 years ago

Tabs with history... link back to parent web page & New tab should open immediately after current tab

Categories

(Firefox :: General, enhancement)

3.6 Branch
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 18808

People

(Reporter: quickemail.007, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US) AppleWebKit/533.2 (KHTML, like Gecko) Chrome/5.0.342.9 Safari/533.2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.9) Gecko/20100401 Ubuntu/9.10 (karmic) Firefox/3.5.9

Having this addon (https://addons.mozilla.org/en-US/firefox/addon/1859) as a default feature in Firefox might be helpful... It would make navigation more easy 

Additionally, if the newly tab in Firefox is made to open immediately after the current tab (similar to Google Chrome), it would be a great User Interface improvement! Because users will not have to go to the last tab to access newly opened tab. The effort that this requires is aggravated when the number of tabs opened in a window is 7 or more. 

Reproducible: Always

Steps to Reproduce:
1. NA
2.
3.


Expected Results:  
1. New tab should have a back button pointing to the parent tab from which it originated... in case user used "Open this link in a new tab"

2. Newly opened tabs should be opened immediately after the current tab, similar to Google Chrome.
Summary: Tabs with history... link back to parent web page and new tab opens immediately after current tab → Tabs with history... link back to parent web page & New tab should open immediately after current tab
Version: unspecified → 3.6 Branch
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
No longer blocks: cuts-tabs
You need to log in before you can comment on or make changes to this bug.