Override for machine name

RESOLVED FIXED in 1.4

Status

RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: pkern, Assigned: Mardak)

Tracking

unspecified
x86
Linux
Points:
---
Bug Flags:
blocking-fx-sync1.4 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.8) Gecko/20100308 Iceweasel/3.5.8 (like Firefox/3.5.8)
Build Identifier: 

An override possibility should be provided for the machine name, for example for computer pools, where every machine has a different name but the profile is in fact the same one on all of them.

Reproducible: Always
(Assignee)

Updated

8 years ago
Assignee: nobody → edilee
Status: UNCONFIRMED → ASSIGNED
Component: Needs Triage → Firefox UI
Ever confirmed: true
Flags: blocking-fx-sync1.4+
QA Contact: needstriage → firefox
(Assignee)

Updated

8 years ago
Target Milestone: --- → 1.4
(Assignee)

Comment 1

8 years ago
Created attachment 450752 [details] [diff] [review]
v1
Attachment #450752 - Flags: review?(mconnor)
(Assignee)

Comment 2

8 years ago
Created attachment 450776 [details]
v1 pref window
(Assignee)

Comment 3

8 years ago
Created attachment 450777 [details]
v1 wizard
(Assignee)

Comment 4

8 years ago
Created attachment 450778 [details]
v1 fennec

Comment 5

8 years ago
(In reply to comment #3)
> Created an attachment (id=450777) [details]
> v1 wizard

I think we want the Computer Name to be above the data types drop down so it doesn't get pushed too far down if the user selects custom settings, but other than that this looks good.

Alex - any thoughts/comments on the UI for giving your devices friendly names?
Current position is fine, the "sync everything" option needs to capture the user's attention.  Not so that they necessarily change it, but so that they are clear that everything is being synced.
pref window location is wrong, IMO, it should be paired with the sync prefs, not with the account details.  If we're going to split the pane, we should use the divisions consistently.

I think I disagree with Alex, since I don't think the "we'll sync everything" message is as important as exposing the computer name.  Changing the computer name to something recognizable is a key thing we want users to do, especially in time for the iPhone launch.

This is pretty unpolished, the widths are inconsistent and make the UI feel more cluttered...

Updated

8 years ago
Attachment #450752 - Flags: review?(mconnor) → review-
(Assignee)

Comment 8

8 years ago
Created attachment 451096 [details] [diff] [review]
v1.1

Computer name now part of Browser Sync prefs in a grid layout
Attachment #450752 - Attachment is obsolete: true
Attachment #451096 - Flags: review?(mconnor)
Comment on attachment 451096 [details] [diff] [review]
v1.1


>diff --git a/services/sync/modules/engines/clients.js b/services/sync/modules/engines/clients.js

>-    return this.localName = Str.sync.get("client.name", [user, app, host]);
>+    return this.localName = Str.sync.get("client.name", [user, app, os]);

we're changing the semantics here, so please change the property name and the comment in the .properties file

>diff --git a/ui/fennec/content/overlay.js b/ui/fennec/content/overlay.js
>--- a/ui/fennec/content/overlay.js
>+++ b/ui/fennec/content/overlay.js
>@@ -115,17 +115,17 @@ let WeaveGlue = {
>   get _settings() {
>     // Do a quick test to see if the options exist yet
>     let syncButton = document.getElementById("weave-syncButton");
>     if (syncButton == null)
>       return;
> 
>     // Get all the setting nodes from the add-ons display
>     let settings = {};
>-    let ids = ["user", "pass", "secret", "connect", "disconnect", "sync"];
>+    let ids = ["user", "pass", "secret", "device", "connect", "disconnect", "sync"];
>     ids.forEach(function(id) {
>       settings[id] = document.getElementById("weave-" + id);
>     });
> 
>     // Replace the getter with the collection of settings
>     delete this._settings;
>     return this._settings = settings;
>   },
>@@ -141,25 +141,27 @@ let WeaveGlue = {
>     if (this._settings == null)
>       return;
> 
>     // Make some aliases
>     let user = this._settings.user;
>     let pass = this._settings.pass;
>     let secret = this._settings.secret;
>     let connect = this._settings.connect;
>+    let device = this._settings.device;
>     let disconnect = this._settings.disconnect;
>     let sync = this._settings.sync;
>     let syncStr = Weave.Str.sync;
> 
>     // Make sure the options are in the right state
>     user.collapsed = loggedIn;
>     pass.collapsed = loggedIn;
>     secret.collapsed = loggedIn;
>     connect.collapsed = loggedIn;
>+    device.collapsed = !loggedIn;
>     disconnect.collapsed = !loggedIn;
>     sync.collapsed = !loggedIn;
> 
>     // Check the lock on a timeout because it's set just after notifying
>     setTimeout(Weave.Utils.bind2(this, function() {
>       // Prevent certain actions when the service is locked
>       if (Weave.Service.locked) {
>         connect.firstChild.disabled = true;
>@@ -199,16 +201,22 @@ let WeaveGlue = {
>       connect.removeAttribute("desc");
>     else if (login != null)
>       connect.setAttribute("desc", Weave.Str.errors.get(login));
> 
>     // Load the values for the string inputs
>     user.value = Weave.Service.username || "";
>     pass.value = Weave.Service.password || "";
>     secret.value = Weave.Service.passphrase || "";
>+    device.value = Weave.Clients.localName;
>+  },
>+
>+  changeName: function changeName(input) {
>+    Weave.Clients.localName = input.value;
>+    input.value = Weave.Clients.localName;

a comment explaining why we round trip localName (to reset the name if it's cleared) would be good.  Same thing for the firefox UI equivalent. 

>diff --git a/ui/firefox/locale/prefs.dtd b/ui/firefox/locale/prefs.dtd

>-<!ENTITY setup.newAccountPrefs.title.label "What do you want &brandShortName; to sync?">
>+<!ENTITY setup.newAccountPrefs.title.label "Browser Sync Preferences">

rename this entity so localizers know the change happened

>+<!ENTITY syncComputerName.label       "Computer name:">

"Computer Name"

r=me with these fixed.
Attachment #451096 - Flags: review?(mconnor) → review+
(Assignee)

Comment 10

8 years ago
http://hg.mozilla.org/services/fx-sync/rev/da5b60ff989d
Allow setting of the computer name during Firefox account setup and from prefs. Also allow setting device name from Fennec prefs. Fix up strings for Fennec.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

8 years ago
Blocks: 580050
You need to log in before you can comment on or make changes to this bug.