Mouse Scroll wheel works inconsistently in the new Add-ons Manager

VERIFIED FIXED in mozilla1.9.3a5

Status

()

defect
P2
normal
VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: lrombes, Unassigned)

Tracking

Trunk
mozilla1.9.3a5
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [AddonsRewriteTestday][rewrite])

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a5pre) Gecko/20100430 Minefield/3.7a3pre Firefox/3.0.10 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a5pre) Gecko/20100430 Minefield/3.7a3pre Firefox/3.0.10 ( .NET CLR 3.5.30729) ID:20100430072714

When the Add-On tab is active the mouse scroll wheel is very sporadic in operation.  When it's first opened the scroll wheel doesn't work at all.  If you click the far scroll bar then the scroll wheel will work.  However, if you move the cursor onto the page it then works sporadically.  For example, it wont' work at first move the cursor slightly then it works.

Reproducible: Always



Expected Results:  
Scroll like any other tab
Reporter

Updated

9 years ago
blocking2.0: --- → ?
Version: unspecified → Trunk
Which type of mouse do you have and which drivers and version are you using?
Summary: Mouse Scroll wheel works inconsistently on Add-On Tab → Mouse Scroll wheel works inconsistently in the new Add-ons Manager
Whiteboard: [AddonsRewriteTestday][rewrite]
Reporter

Comment 2

9 years ago
I have an old Dell ball mouse with a scroll wheel on it.  It is just using the generic Windows XP driver.

It works fine on web page tabs.  However, when I'm in the new Add-On Manager tab I get two scroll bars.  The inside scroll bar is the full length of the list of extensions the outside bar becomes active only if I move the mouse over it and either use the wheel or the first button.  Once I have made the outside scroll bar active I can then move the mouse cursor into the main screen of the Add-On tab and it then scrolls up and down the list of extensions sporadically. 

It's strange because once I get it to work as long as I'm moving the mouse the scroll wheel will work, but once I stop moving the cursor the scroll wheel stops.  If I move it again - I do not need to return to the outside scroll bar - it works.
This will probably just be fixed by bug 554237 then.
Depends on: 554237
marking as new as I was able to reproduce this in the lab
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2
Looks like this is caused by the double scrollbars. After setting the focus to the inner scrollbox scrolling works fine.
I'm pretty sure that bug 554237 will have fixed this, please reopen if that is not the case.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a5
verified with touchpad scrolling... would be good to verify with a mouse scrollwheel as well
Reporter

Comment 8

9 years ago
Works with the scrollwheel on my mouse now.  Thank you!
Flags: in-testsuite?
Flags: in-litmus-
OS: Windows XP → All
Hardware: x86 → All
blocking2.0: ? → ---
Don't think this is something we can easily test automatically but I do expect nightly users to spot it quickly so I think we're safe without.
Flags: in-testsuite? → in-testsuite-
You need to log in before you can comment on or make changes to this bug.