Extensions with no text information should not show "undefined"

RESOLVED DUPLICATE of bug 562848

Status

()

P2
normal
RESOLVED DUPLICATE of bug 562848
9 years ago
9 years ago

People

(Reporter: tchung, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [AddonsRewriteTestday][rewrite], URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Created attachment 442720 [details]
undefined screenshot

For extensions that dont have textual information like details, versions, etc.. we should not show "Undefined".  better off just leaving the textarea blank.

* See screenshot

1) install nightly Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US;
rv:1.9.3a5pre) Gecko/20100430 Minefield/3.7a5pre
2) install a extension with no details (eg. http://www.getpersonas.com/en-US/persona/164510)
3) verify the description is showing undefined in extension and detail view

Expected:
- replace "Undefined" with blank or something of use.

Comment 1

9 years ago
undefined is useful, it lets you know that the extension viewer didn't choke on malformed data, and that there is nothing available for viewing
Blocks: 562902
Keywords: uiwanted
OS: Mac OS X → All
Hardware: x86 → All
No longer blocks: 550048, 562902
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Keywords: uiwanted
Priority: -- → P2
Resolution: --- → DUPLICATE
Duplicate of bug: 562848
You need to log in before you can comment on or make changes to this bug.