Closed Bug 562962 Opened 10 years ago Closed 10 years ago

unit test fail: reftest/tests/layout/reftests/editor/xul/empty-1.xul

Categories

(Core :: DOM: Editor, defect)

All
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla1.9.3a5

People

(Reporter: anodelman, Assigned: ehsan)

References

Details

Attachments

(4 files)

WINNT 6.1 mozilla-central opt test reftest
REFTEST TEST-UNEXPECTED-FAIL | file:///c:/talos-slave/mozilla-central-win7-opt-u-reftest/build/reftest/tests/layout/reftests/editor/xul/empty-1.xul |
REFTEST number of differing pixels: 90
Alice, what theme do the machines which you see this failure on use?  Can you load the following URL in a browser window and attach a screenshot of it?

data:application/vnd.mozilla.xul+xml,<?xml version="1.0"?><?xml-stylesheet href="chrome://global/skin" type="text/css"?><window xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"><textbox placeholder="test"/></window>
Assignee: nobody → ehsan
Status: NEW → ASSIGNED
Whiteboard: [waiting for info from releng]
ping?
Attached image screenshot
Does this show you what you need? Ping me if you need something else.
Attachment #447514 - Flags: feedback?(ehsan)
Comment on attachment 447514 [details]
screenshot

Please submit a screenshot of how the test case looks by just loading it in the address bar (without focusing the textbox and/or entering text into it.)  Thanks!
Attachment #447514 - Flags: feedback?(ehsan) → feedback-
Attached image screenshot
I hope I got it right this time.
Attachment #447785 - Flags: feedback?(ehsan)
Comment on attachment 447785 [details]
screenshot

Yes, this screenshot is what I needed.  Thanks!
Attachment #447785 - Flags: feedback?(ehsan) → feedback+
Attached patch Patch (v1)Splinter Review
Seems like the italic style for windows-default-theme was disabled in bug 547224.  I commented it out for now, and added a note to make sure that we won't forget to update it back when we take the fix for bug 457801.
Attachment #447867 - Flags: review?(roc)
CCing Dao to keep him in the circle here.
http://hg.mozilla.org/mozilla-central/rev/8893eef77dcd
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Whiteboard: [waiting for info from releng]
Target Milestone: --- → mozilla1.9.3a5
You need to log in before you can comment on or make changes to this bug.