Last Comment Bug 563191 - deprecated conversion from string constant to char* in nsAuthSambaNTLM::SpawnNTLMAuthHelper
: deprecated conversion from string constant to char* in nsAuthSambaNTLM::Spawn...
Status: RESOLVED FIXED
[build_warning]
:
Product: Core
Classification: Components
Component: Networking (show other bugs)
: Trunk
: All All
: -- trivial (vote)
: mozilla16
Assigned To: timeless
:
Mentors:
: 576659 666619 (view as bug list)
Depends on: 563192
Blocks: buildwarning
  Show dependency treegraph
 
Reported: 2010-05-01 16:52 PDT by timeless
Modified: 2012-07-13 05:45 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (970 bytes, patch)
2010-05-01 17:06 PDT, timeless
no flags Details | Diff | Review
patch 2 (1.74 KB, patch)
2012-07-10 23:09 PDT, Cameron McCormack (:heycam)
ehsan: review+
Details | Diff | Review

Description timeless 2010-05-01 16:52:41 PDT
extensions/auth/nsAuthSambaNTLM.cpp: In member function ‘nsresult nsAuthSambaNTLM::SpawnNTLMAuthHelper()’:
nsAuthSambaNTLM.cpp:213:
 warning: deprecated conversion from string constant to ‘char*’
 warning: deprecated conversion from string constant to ‘char*’
 warning: deprecated conversion from string constant to ‘char*’
 warning: deprecated conversion from string constant to ‘char*’
 warning: deprecated conversion from string constant to ‘char*’

    char* args[] = {
        "ntlm_auth",
        "--helper-protocol", "ntlmssp-client-1",
        "--use-cached-creds",
        "--username", const_cast<char*>(username),
        nsnull
    };

this should be const char * const args[], however we can't do that today because the NSPR prototype isn't friendly (see blocker bug).
Comment 1 timeless 2010-05-01 17:06:41 PDT
Created attachment 442950 [details] [diff] [review]
patch

this can't be reviewed or pushed until the blocking bug is fixed.
Comment 2 Josh Matthews [:jdm] 2010-07-02 17:37:50 PDT
*** Bug 576659 has been marked as a duplicate of this bug. ***
Comment 3 Josh Matthews [:jdm] 2011-06-23 10:42:12 PDT
*** Bug 666619 has been marked as a duplicate of this bug. ***
Comment 4 Zack Weinberg (:zwol) 2011-06-23 12:44:38 PDT
There is a patch in the blocking bug (bug 563192), which has gone unreviewed for over a year.  I have pinged it.  I don't know if there is anything else that can be done to get this unjammed.
Comment 5 Joey Armstrong [:joey] 2011-06-23 14:18:48 PDT
(In reply to comment #4)
> There is a patch in the blocking bug (bug 563192), which has gone unreviewed
> for over a year.  I have pinged it.  I don't know if there is anything else
> that can be done to get this unjammed.

A few suggestions that were made:
  o poking people is good
  o finding component/module owners and poking them
  o and if important, poking product drivers
  o something to bring up at various triage meetings.
  - there are flags you can set that make it show up for various triage meetings as well.
Comment 6 Cameron McCormack (:heycam) 2012-07-10 23:09:38 PDT
Created attachment 640932 [details] [diff] [review]
patch 2

How about this instead?  (Saw this clang warning flying by and thought I'd grab it.)
Comment 7 Cameron McCormack (:heycam) 2012-07-11 18:05:59 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/f14591911ad8
Comment 8 Ed Morley [:emorley] 2012-07-12 09:36:45 PDT
https://hg.mozilla.org/mozilla-central/rev/f14591911ad8

Note You need to log in before you can comment on or make changes to this bug.