potetial memory leak on pages using flash

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
8 years ago
2 years ago

People

(Reporter: fabian.zimmermann, Unassigned)

Tracking

3.6 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupeme?])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

Firefox uses plenty of memory for displaying flash but doesn't ublock it once you leave the page.

Reproducible: Always

Steps to Reproduce:
1. open google.com
2. go to a site using flash, e.g. http://www.zdf.de/ZDFmediathek/hauptnavigation/startseite#/hauptnavigation/startseite
3. go back to google.com

also if flash page is opened in a different tab and then closed.
Actual Results:  
memory remains blocked. Once the blocked memory accumulates, Firefox freezes.


I recorded the issue using Windows 7 PSR, but somehow I cannot figure out how to attach files here.

Comment 1

8 years ago
The memory is used by the plugin, not the browser. Are you sure you run the latest version of Flash ?

(and this issue has been filed dozens of times before)

Updated

8 years ago
Severity: critical → normal
Version: unspecified → 3.6 Branch

Comment 2

7 years ago
dup of bug 501485?

Updated

6 years ago
Whiteboard: [dupeme?]
This bug is valid for 8.0a2, the plugin container process leaks 5MB of memory each time that site is opened and closed. Most probably it's a Flash bug.
We can see if resolving bug 501485 will resolve also this.
Depends on: 501485

Comment 4

6 years ago
Any change?

Comment 5

4 years ago
(In reply to Marco Castelluccio [:marco] from comment #3)
> This bug is valid for 8.0a2, the plugin container process leaks 5MB of
> memory each time that site is opened and closed. Most probably it's a Flash
> bug.
> We can see if resolving bug 501485 will resolve also this.

any change?
Flags: needinfo?(fabian.zimmermann)

Comment 6

2 years ago
I do not see a problem
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(fabian.zimmermann)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.