Closed Bug 56325 Opened 24 years ago Closed 24 years ago

Cursor too short when clicking past end of line break in textarea

Categories

(Core :: DOM: Editor, defect, P3)

defect

Tracking

()

VERIFIED DUPLICATE of bug 53610
Future

People

(Reporter: sgifford+mozilla-old, Assigned: sfraser_bugs)

Details

If I am entering text into a textarea and click past the end of a line of text,
the cursor is raised slightly.  It behaves correctly, but is weird looking.

When I begin to type, the cursor returns to its normal position.  However, if I
type a single character, then press Backspace, the cusor returns to its raised
position.  I don't see this if I type multiple characters and backspace through
all of them.
reassigning
Assignee: rods → beppe
End-of-line caret bug, known issue.
Assignee: beppe → sfraser
Status: UNCONFIRMED → NEW
Component: HTML Form Controls → Editor
Ever confirmed: true
Target Milestone: --- → Future
This same bug seems to be causing two other strange behaviors.

First, if I am in a TEXTAREA and have text selected elsewhere, when I
middle-click past the end of line to paste it, it pastes incorrectly, sometimes
going down to the next line, sometimes jumping up and pasting there (!)

Second, if I start hilighting multiple lines from an area past the end of a line
(with the raised caret), overtype works incorrectly, only overtyping the first
line and leaving the other lines hilighted.
Status: NEW → ASSIGNED
Reproduced in build 2000102008, Mac OS 9.0 --> All/All. Note that it only
happens at the end of a hard line break, not a soft (wrapped) line break.
OS: Linux → All
Hardware: PC → All
Summary: Cursor appears raised when clicking past end of line in textarea → Cursor too short when clicking past end of line break in textarea


*** This bug has been marked as a duplicate of 53610 ***
Status: ASSIGNED → RESOLVED
Closed: 24 years ago
Resolution: --- → DUPLICATE
verified in 10/30 build
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.