Closed Bug 563546 Opened 10 years ago Closed 10 years ago

Newly opened page is a little bit scrolled down, when opened in new tab

Categories

(Firefox for Android Graveyard :: General, defect)

Fennec 1.1
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: martijn.martijn, Assigned: mfinkle)

Details

(Whiteboard: [need-1.1-ver])

Attachments

(1 file)

To reproduce:
- Visit a page that you can scroll, and has a couple of links (like this bug page).
- Scroll down a little bit, then click and hold, to get the "Open Link in New Tab" dialog and click on that dialog.
- Switch to that new tab

Expected result:
The newly opened page should start at the top, you should not be able to pan downwards to scroll the page up.

Actual result:
The newly opened page starts at a scrolling position that seems to correspond to the height of the url bar. You can pan downwards to scroll the page up.
Also notice how this effect doesn't occur when the referring page hasn't been scrolled down.
OK, after looking at this bug I have some info and questions:

* When i switch to the second tab _and_ horizontally move the tab bar out of view, the page looks fine
* It seems like the URLbar is floating over the top of the webpage because the tab sidebar is visible (which is normal)
* Does this make sense? Do you see the same thing?

I'll look into why the URLBar itself is not scrolled into view, which would mean the floating URLBar behavior would not be covering the web content at all.
Attached patch patchSplinter Review
This patch sets the pageScrollOffset for a tab if it is a background tab. When the tab is selected, the page scroller is correctly positioned.
Assignee: nobody → mark.finkle
Attachment #443617 - Flags: review?(21)
Attachment #443617 - Flags: feedback?(mbrubeck)
tracking-fennec: --- → ?
Flags: in-litmus?
Comment on attachment 443617 [details] [diff] [review]
patch

Sorry I have missed the pageScrollOffset when doing the initial patch for background tab scrolling.
Attachment #443617 - Flags: review?(21) → review+
Attachment #443617 - Flags: feedback?(mbrubeck) → feedback+
Comment on attachment 443617 [details] [diff] [review]
patch

Looks right to me.

I noticed a very minor typo in this comment (not part this patch):

>        // We're about to have new page content, to scroll the content area
>        // to the top so the new paints will draw correctly.

s/to scroll/so scroll/
pushed to m-b:
http://hg.mozilla.org/mobile-browser/rev/05f1b35d789b

allowing to bake before psuhing to m-1.1
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
verified FIXED on trunk:


Mozilla/5.0 (X11; U; Linux armv71; Nokia N900; en-US; rv:1.9.3a5pre) Gecko/20100506 Namoroka/3.7a5pre Fennec/2.0a1pre
OS: Windows 7 → All
Hardware: x86 → All
Whiteboard: [need-1.1-ver]
I'm reassigning this to myself for adding litmus testcases for this (aakashd
discussed this on irc with blassey and ted on #mobile).
Assignee: mark.finkle → martijn.martijn
Assignee: martijn.martijn → mark.finkle
Flags: in-litmus? → in-litmus?(martijn.martijn)
Flags: in-litmus?(martijn.martijn) → in-litmus?
Flags: in-litmus? → in-litmus?(martijn.martijn)
Flags: in-litmus?(martijn.martijn) → in-litmus?
Flags: in-litmus? → in-litmus?(martijn.martijn)
https://litmus.mozilla.org/show_test.cgi?id=15191
Flags: in-litmus?(martijn.martijn) → in-litmus+
VERIFIED FIXED on:
Build ID: Mozilla /5.0 (Android;Linux armv7l;rv:2.0b13pre) Gecko/20110315 Firefox/4.0b13pre Fennec /4.0b6pre
Device: HTC Desire
Status: RESOLVED → VERIFIED
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.