Closed Bug 563560 Opened 10 years ago Closed 6 years ago

Nike Running / Nike+ website unusable in FF 3.6 / trunk

Categories

(Web Compatibility :: Desktop, defect, major)

defect
Not set
major

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: gal, Unassigned)

References

()

Details

Attachments

(3 files)

Its a flash-heavy website.

http://nikerunning.nike.com/nikeos/p/nikeplus/en_US/

Everything is out of whack. Controls are not reachable because something floats over it. Works in WebKit.

Its a popular site so I think we should try to get them to fix it, or maybe look into why we render so poorly here.
seems to WFM. are you on the latest trunk?
I was using 3.6.4 and a custom minefield debug build. I will try a nightly. I tried product flash and 10.1 beta, btw.
Attached image firefox nightly
Attached image safari
Yeah, trunk fails too. Its messed up even worse inside (behind the login). Completely unusable. You can't click away "dialog" floats and such.
Note: the website behaves pretty wonky with safari, too, that's why I filed it under evangelism. I think Nike needs a talking to about web-standards and cross browser testing. It works well in IE, of course.
this looks like:

1) A nightly from a few days ago

or

2) An issue with the 10.1 beta plugin
I just tried with a nightly from this morning and the problem existed before I installed the 10.1 beta plugin an hour ago (I installed it to see whether it makes a difference). 3.6.4 doens't work either, with neither plugin.
Attached image my mac
well, then, what's up? cause it looks fine here.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.3a5pre) Gecko/20100503 Minefield/3.7a5pre
Super weird. I will downgrade plugins and test.
so, this looks like it might be 10.6-related. I am on 10.5. can someone on 10.6 inspect?
The f$%^#$ flash installer doesn't let me downgrade. I will try to exchange the plugin by hand.
Works fine in a recent Camino (Gecko 1.9.2) nightly on 10.6 with a 10.0.x version of Flash.

Works fine in Minefield (Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a5pre) Gecko/20100503 Minefield/3.7a5pre), too, with the same Flash version.

Andreas: Try using your current Flash installer to uninstall, then install fresh. I believe I've used that in the past as a trick to work around that stupid "newer version blocks installation" check.
The site redirects to http://www.nike.com/jp/ja_jp/c/running/ here in Japan.
But I expect it will be the same elsewhere. This type of brands change their site very often. 
So the issue is probably invalid by now because the site has completely changed.
Assignee: english-us → nobody
Status: NEW → RESOLVED
Closed: 6 years ago
Component: English US → Desktop
Resolution: --- → INVALID
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.