"Report A Broken Website" says "Build Config" is unknown but "about:buildconfig" knows

RESOLVED INCOMPLETE

Status

--
minor
RESOLVED INCOMPLETE
9 years ago
2 years ago

People

(Reporter: rob1weld, Assigned: raccettura)

Tracking

Details

(Whiteboard: [testday-20110603], URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 ( .NET CLR 3.5.30729)

The [Help][Report A Broken Website] says my "Build Config" is unknown but "about:buildconfig" shows this:

----------

about:buildconfig

Source

Built from http://hg.mozilla.org/releases/mozilla-1.9.2/rev/28ef231a65a3
Build platform
target
i686-pc-mingw32

Build tools
Compiler 	Version 	Compiler flags
cl 	14.00.50727.762 	-TC -nologo -W3 -Gy -Fdgenerated.pdb -DNDEBUG -DTRIMMED -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1
cl 	14.00.50727.762 	-GR- -TP -nologo -Zc:wchar_t- -W3 -Gy -Fdgenerated.pdb -DNDEBUG -DTRIMMED -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1

Configure arguments
--enable-application=browser --enable-update-channel=release --enable-update-packaging --enable-jemalloc --enable-official-branding --enable-tests 

----------

Since we could not fit all that info into one line we could show the "Built from" line from "about:buildconfig" instead of wasting a line to say "Unknown".

Rob


Reproducible: Always

Updated

9 years ago
Assignee: nobody → robert
Component: General → Reporter
Product: Firefox → Webtools
QA Contact: general → reporter
Version: unspecified → other
(Reporter)

Comment 1

8 years ago
Bump. Six months and ten versions have passed since this was Posted. It is Assigned, how is it's progress, do you need help or a reassignment ?

Thanks,
Rob

Comment 2

7 years ago
But it was never confirmed. It seems the menu item "Report A Broken Website" was removed in Firefox 4. Is this still relevant?
Whiteboard: [testday-20110603]
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 3

7 years ago
(In reply to comment #2)
> But it was never confirmed. It seems the menu item "Report A Broken Website"
> was removed in Firefox 4. Is this still relevant?

If we distribute Firefox 3.6.x then it is.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
Not a crash fix, won't get into a 3.6.x stability release.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 5

7 years ago
OK. Only "crash fixes" for 3.6.x (no 'cosmetics' RFE, usability not related to a crash, etc.).

Thanks for clearing that up Kevin.
Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.