Context Menu should pop up on mouse down

VERIFIED DUPLICATE of bug 49844

Status

()

Core
Event Handling
P3
normal
VERIFIED DUPLICATE of bug 49844
17 years ago
17 years ago

People

(Reporter: Brian, Assigned: joki (gone))

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I played around with some applications, and they all behave differently, so I
don't think there is a standard, but NS 4 and earlier had it pop up on mouse
down, this is nice because you can do things like this:
mouse down, select back, mouse up
mouse down, select save image, mouse up

the way it is now, you have to do this:
mouse down, mouse up, select back, mouse down, mouse up

Also, when it comes up on mouse up, it makes the UI feel "laggy."  Even though
it really isn't laggy, it kinda feels that way with the popup menus for this reason.

There's really no reason to wait for mouse up is there?

Comment 1

17 years ago
I tested this on Linux build 2000-10-10-15.  Results:
The context menu does pop up "onMouseDown", but menu items cannot be selected
with click-point-release" as in other X applications I'm using - you'll have to
use the "click-release-point-click-release" way.

There might be two different bugs here, one of which seems to be Windows-only. 
Investigating further.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
This one is a dup of bug 49844, and the other problem I noticed is bug 16766.

*** This bug has been marked as a duplicate of 49844 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
VERIFIED.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.