Closed Bug 563919 Opened 10 years ago Closed 6 years ago

Facebook landing page background looks bad in Fennec or in narrow browser windows

Categories

(Web Compatibility :: Desktop, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: senthilkumar.r, Unassigned)

References

()

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: fasebook site (alignment error)

fase book  site _right side part ( singn up ,email,password (login button ) alignment error 

Reproducible: Always

Steps to Reproduce:
1.open www.fasebook.com
2.right site part(alignment error)
3.
Actual Results:  
fase book site _right side part ( singn up ,email,password (login button ) alignment error
I think you mean http://www.facebook.com - www.fasebook.com appears to be a broken site with no content.  Updating the summary and URL.

It looks like the facebook.com landing page for logged-out users has a background that does not extend past the viewport, making it render incorrectly in Fennec (with the default 800px viewport) or in any browser window less than 960px wide.

This is not just a Fennec problem - it also happens in Firefox and in other browsers (e.g. Chrome) when the window is narrow.  Reassigning to tech evangelism.

Facebook could fix this problem on all browsers by making the background extend past the viewport, or just on mobile browsers like Fennec by adding <meta name="viewport" content="width=980"> to the head of their page.
Assignee: nobody → english-us
Status: UNCONFIRMED → NEW
Component: General → English US
Ever confirmed: true
OS: Windows XP → All
Product: Fennec → Tech Evangelism
QA Contact: general → english-us
Hardware: x86 → All
Summary: fasebook site (alignment error) → Facebook landing page background looks bad in Fennec or in narrow browser windows
Version: Trunk → unspecified
It looks like this is still a problem. I'll CC Ilya on this and maybe he can bring it to the attention of the right people over there.
I was messing around with this and was surprised to see that Facebook seems to send a great looking website to any webkit based browser (chrome) and a crappy looking website to Firefox. See the screenshot.

I modified the Firefox user agent and verified that the Webkit version looks find in Firefox except for a small issue with the search button.

So we should really evangelize Facebook and find out why they are making mobile facebook look better on Chrome then Firefox.
So the bug was about alignment on form elements on the right side of the page.
I do not see any issues.

I'm closing it as WORKSFORME. In case they are  issues for very specific parts of the site. Open individual bugs for each issues.
Assignee: english-us → nobody
Status: NEW → RESOLVED
Closed: 6 years ago
Component: English US → Desktop
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.