"ASSERTION: Nodes that are not documents, document fragments or elements can't be parents" with doctype node

VERIFIED DUPLICATE of bug 613793

Status

()

VERIFIED DUPLICATE of bug 613793
9 years ago
8 years ago

People

(Reporter: jruderman, Unassigned)

Tracking

(Blocks: 1 bug, {assertion, testcase})

Trunk
mozilla2.0b8
assertion, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Created attachment 443737 [details]
testcase

Similar to bug 558973 (which is fixed) but with a more complicated testcase.

###!!! ASSERTION: Nodes that are not documents, document fragments or elements can't be parents!: 'aParent->IsNodeOfType(nsINode::eDOCUMENT) || aParent->IsNodeOfType(nsINode::eDOCUMENT_FRAGMENT) || aParent->IsElement()', file /Users/jruderman/mozilla-central/content/base/src/nsGenericElement.cpp, line 3863
Bleh, nsDOMDocumentType are nsGenericDOMDataNode but not IsNodeOfType(eDATA_NODE). Should I just add a flag for "can have children"?
Assignee: nobody → peterv
Status: NEW → ASSIGNED
OS: Mac OS X → All
Hardware: x86 → All
Target Milestone: --- → mozilla1.9.3a5
Where would we use this flag, other than asserts?
(Reporter)

Updated

8 years ago
Blocks: 613793
(Reporter)

Comment 3

8 years ago
WFM:

JavaScript error: , line 0: uncaught exception: [Exception... "Node cannot be inserted at the specified point in the hierarchy"  code: "3" nsresult: "0x80530003 (NS_ERROR_DOM_HIERARCHY_REQUEST_ERR)"  location: "https://bug564047.bugzilla.mozilla.org/attachment.cgi?id=443737 Line: 6"]

Fix by the patch in bug 613793, perhaps? I know it made NS_ERROR_DOM_HIERARCHY_REQUEST_ERR occur in some cases where it didn't occur before.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
> Fix by the patch in bug 613793, perhaps? 

Very much so, yes.
No longer blocks: 613793
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 613793
Assignee: peterv → nobody
Status: RESOLVED → VERIFIED
Target Milestone: mozilla1.9.3a5 → mozilla2.0b8
You need to log in before you can comment on or make changes to this bug.