If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

N601 & M08 crash [@ libgdk-1.2.so.0 - handle_key_release_event] segmentation fault closing window with control-w key stroke

VERIFIED FIXED in Future

Status

()

Core
Keyboard: Navigation
P1
critical
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: Stephen Sayer, Assigned: Chris McAfee)

Tracking

({crash, helpwanted, topcrash})

Trunk
Future
x86
Linux
crash, helpwanted, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Needs Mandrake investigation. Possible gtk 1.2.7 bug, 1.2.8 may fix, crash signature)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Mozilla/5.0 (X11; U; Linux 2.2.17ss i686; en-US; m18) Gecko/20001010

Anytime I close a window (browser, mail, etc.) Mozilla crashes with a
segmetation fault logging the following error to the console:

./run-mozilla.sh: line 72:  6239 Segmentation fault      $prog ${1+"$@"}

Comment 1

17 years ago
I'm not crashing there on Linux 2000-10-12-21-MTrunk.  It is highly unlikely
that this actually belongs to keyboard navigation.
Severity: major → critical
Keywords: crash

Comment 2

17 years ago
works for me (linux build id: 101308)
(Reporter)

Comment 3

17 years ago
Found this on Build ID 2000101015 and should have mentioned that control-w works
OK only when closing the last Mozilla window open (program exits fine). When
there are more than one windows open however it crashes on that build for me
without fail.

Also tested this in KDE as well as Gnome on my Mandrake Linux 7.1 install.
Target Milestone: --- → M18
weird, tried doing that (closing via ctrl+w when there's more than 1 browser
window open) using mozilla trunk bits 2000.10.11.08 on linux Redhat 6.2.

stephen, could you pls try this out on a more recent build? thx!
(Reporter)

Comment 5

17 years ago
Created attachment 17104 [details]
Debug output and rpm -qi on libgtk+
(Reporter)

Comment 6

17 years ago
Just attached debug output from build id 101309 run which appears to seg fault
in libgdk (libgtk+ 1.2.7). At the end is rpm -i output on the libgtk+ rpm this
library hails from. Debugging under kde and gnome crash in the same place.

I downloaded the source too and can try to build and run with symbols if necessary.

Comment 7

17 years ago
Chris, can you take a look at this?
Assignee: don → mcafee

Comment 8

17 years ago
I see this on Linux 2000102009. Working from last opened to first opened, it
works, when I open multiple and close the "parent" window, mozilla crashes. Now
Ctrl-W doesn't work at all on my build. 
(Assignee)

Comment 9

17 years ago
This worksforme, trunk and branch, linux rh60.
I am using gtk 1.2.3.
(Assignee)

Comment 10

17 years ago
I explored the following vectors: window manager, gtk version,
trunk/branch, debug/opt, and I think this is a gtk version problem.

I get the following assert on pavlov's machine, any wm, trunk & branch,
debug:

Gdk-CRITICAL **: file gdkwindow.c: line 716 (gdk_window_ref): assertion `window
!= NULL' failed.

optimized does not crash. stephen, do you see this assert?
Pavlov has gtk+ 1.2.8.  Assert does not show up for an optimized
build and does NOT crash as in stephen's case.


 
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 11

17 years ago
oh, I also tried wm-close and file-close instead of ctrl-w,
this only happens for ctrl-w.
(Assignee)

Comment 12

17 years ago
nsbeta1, we need to fix newer gtk usage if necessary
Keywords: nsbeta1
(Assignee)

Comment 13

17 years ago
*** Bug 63342 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

17 years ago
Priority: P3 → P1
Target Milestone: M18 → ---

Updated

17 years ago
Target Milestone: --- → mozilla0.8
(Assignee)

Comment 14

17 years ago
I tried this on rh62 with both gtk 1.2.6 and 1.2.8, debug & opt, I could not
get this to crash and I don't see the assertion we were seeing earlier.
Marking WorksForMe, please reopen if this is still crashing and/or
you have more data.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 15

17 years ago
Reopening bug. This bug still in the top 20 in rel N601. (Adding N601 to the 
summary for tracking.) Compares to dupe bug 63342. Questionable that it belongs 
under Keyboard Navigation.

Stack Trace: 

         libc.so.6 + 0x90674 (0x402d6674)  
         libX11.so.6 + 0x4bfb7 (0x406bbfb7)  
         libX11.so.6 + 0x4cab3 (0x406bcab3)  
         libX11.so.6 + 0x31aac (0x406a1aac)  
         libX11.so.6 + 0x319c4 (0x406a19c4)  
         libX11.so.6 + 0x31b9c (0x406a1b9c)  
         libX11.so.6 + 0x26b2f (0x40696b2f)  
         libgdk-1.2.so.0 + 0x16bfa (0x40622bfa)  
         libgdk-1.2.so.0 + 0x16dd6 (0x40622dd6)  
         libglib-1.2.so.0 + 0x102d9 (0x406522d9)  
         libglib-1.2.so.0 + 0x108e3 (0x406528e3)  
         libglib-1.2.so.0 + 0x10a7c (0x40652a7c)  
         libgtk-1.2.so.0 + 0x8dd97 (0x40575d97)  
         nsAppShell::Run()  
         nsAppShellService::Run()  
         main1()  
         main()  
         libc.so.6 + 0x18a42 (0x4025ea42)

URL:(26928014) www.weather.com
        Comment: (26928039) i was creating a new folder to manage my bookmarks 
-- this is the second time n6 has crashed while doing this same action.
        Comment: (26917650) Trying to create a new folder in my bookmarks
        Comment: (26928014) i had just typed in a invalid domain name
        Comment: (26974141) Logging into a page protected by a .htaccess file.
        Comment: (26970652) Attempting to retrieve e-mail from local POP3 server 
and... kaboom.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Summary: segmentation fault closing window with control-w key stroke → N601 segmentation fault closing window with control-w key stroke
(Assignee)

Comment 16

17 years ago
crash reporters: I need help reproducing this.  I am
guessing that it's a problem with gtk 1.2.7, please
try 1.2.8.  gtk-config --version will tell you what you are running.

I've looked at this a few times and cannot reproduce this.
I don't think this is something we can expect to fix for
nsbeta1/.9 until I can find a way to reproduce this.
Target Milestone: mozilla0.8 → mozilla0.9
(Reporter)

Comment 17

17 years ago
I haven't seen this crash in any builds since I started running Mandrake 7.2
which uses gtk version 1.2.8 although I do get the assertion. Running Build ID
2001022608 right now I can open a new window then click the display frame to
focus and hit control-w and I get the following assertion in console using my
gtk 1.2.8:
Gdk-CRITICAL **: file gdkwindow.c: line 716 (gdk_window_ref): assertion `window
!= NULL' failed.

In summary I am able to get the assertion but no longer able to reproduce the
crash while running gtk 1.2.8.
(Reporter)

Comment 18

17 years ago
I believe I may have more relevant information about this. It's looking now that
this may be "My side bar" related in some way. It appears initially that new
windows created by a parent with the side bar enabled are the ones that throw
the assertion when closed with control-w.

For the most part I've previously been running with the side bar showing or
collapsed but not turned off (via F9 or menu).

I'm attaching a test case procedure that for me is repeatable.

I hope this helps!
(Reporter)

Comment 19

17 years ago
Created attachment 26376 [details]
Test case procedure suggesting involvement of "My side bar"
(Reporter)

Comment 20

17 years ago
Adding Sidebar component owners matt@netscape.com and sujay@netscape.com to CC.
(Assignee)

Comment 21

17 years ago
ssayer: thanks for the clue.

Comment 22

17 years ago
Mass moving most of mozilla0.9 bugs to mozilla0.8.1
Target Milestone: mozilla0.9 → mozilla0.8.1

Comment 23

17 years ago
This is showing up as a topcrash for mozilla 0.8 under the libgdk-1.2.so.0 stack 
signature, but the real crash is at handle_key_release_event. Adding topcrash 
keyword and M08 for tracking. Here is the 
latest stack trace and some talkback info to help reproduce (from the mozilla 
0.8 build):

Incident ID 27141120 
libgdk-1.2.so.0 + 0x241c2 (0x405d61c2) 
libgdk-1.2.so.0 + 0x1448d (0x405c648d) 
libgdk-1.2.so.0 + 0x143eb (0x405c63eb) 
handle_key_release_event() 
dispatch_superwin_event() 
handle_gdk_event() 
libgdk-1.2.so.0 + 0x15b80 (0x405c7b80) 
libglib-1.2.so.0 + 0x10736 (0x405f0736) 
libglib-1.2.so.0 + 0x10d43 (0x405f0d43) 
libglib-1.2.so.0 + 0x10eec (0x405f0eec) 
libgtk-1.2.so.0 + 0x785d9 (0x405495d9) 
nsAppShell::Run() 
nsAppShellService::Run() 
main1() 
main() 
libc.so.6 + 0x18cae (0x40251cae) 

libgdk-1.2.so.0 + 0x241c2 (0x405d61c2) 6570a6d8
         line 
        Build: 2001021504 CrashDate: 2001-03-01 UptimeMinutes: 2677  Total: 7214 
        OS: Linux 2.2.15-4mdksmp
        URL: 
        Comment: Pressing CTRL-W to close the page (2 browser windows open) 
caused the crash. I have been browsing for about 30 mins.
         Detailed : http://cyclone/reports/incidenttemplate.cfm?bbid=27141120
         StackTrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=27141120
libgdk-1.2.so.0 + 0x241c2 (0x006e51c2) 1209e6ec
         line 
        Build: 2001021504 CrashDate: 2001-02-23 UptimeMinutes: 9  Total: 40 
        OS: Linux 2.2.15-4mdksecure
        URL: www.openoffice.org
        Comment: I was trying to go to linux-mandrake.com using the shertcut key 
cntl-l
         Detailed : http://cyclone/reports/incidenttemplate.cfm?bbid=26821483
         StackTrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=26821483
libgdk-1.2.so.0 + 0x241c2 (0x405d51c2) 8f1c1a9d
         line 
        Build: 2001021504 CrashDate: 2001-02-26 UptimeMinutes: 21  Total: 97 
        OS: Linux 2.2.17
        URL: 
        Comment: Ctrl-W to close a window
         Detailed : http://cyclone/reports/incidenttemplate.cfm?bbid=26972229
         StackTrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=26972229
libgdk-1.2.so.0 + 0x241c2 (0x405d61c2) 6570a6d8
         line 
        Build: 2001021504 CrashDate: 2001-03-06 UptimeMinutes: 108  Total: 14322 
        OS: Linux 2.2.15-4mdksmp
        URL: 
        Comment: I typed in a search term on Google.The browser popped upa 
window telling me that this information wasinsecure ...I hit 'enter' on the 
keyboard (I usually 'click' the 'OK' button).Boom.
         Detailed : http://cyclone/reports/incidenttemplate.cfm?bbid=27378125
         StackTrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=27378125
libgdk-1.2.so.0 + 0x241c2 (0x006e51c2) 1209e6ec
         line 
        Build: 2001021504 CrashDate: 2001-03-06 UptimeMinutes: 494  Total: 534 
        OS: Linux 2.2.15-4mdksecure
        URL: www.linux-mandrake.com
        Comment: Using cntrl-lGoing to www.adobe.com
         Detailed : http://cyclone/reports/incidenttemplate.cfm?bbid=27416818
         StackTrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=27416818

Keywords: topcrash
Summary: N601 segmentation fault closing window with control-w key stroke → N601 & M08 crash [libgdk-1.2.so.0 - handle_key_release_event] segmentation fault closing window with control-w key stroke

Updated

17 years ago
Summary: N601 & M08 crash [libgdk-1.2.so.0 - handle_key_release_event] segmentation fault closing window with control-w key stroke → N601 & M08 crash [@ libgdk-1.2.so.0 - handle_key_release_event] segmentation fault closing window with control-w key stroke

Comment 24

17 years ago
Stephen Sayer mentioned something about the sidebar being involved with this 
crash.  The only entry I found with this stack trace and sidebar mentioned in th 
e comments in today's report is:

libgdk-1.2.so.0 + 0x241c2 (0x405d61c2) 6570a6d8
         line 
        Build: 2001021504 CrashDate: 2001-03-02 UptimeMinutes: 1419  Total: 8633 
        OS: Linux 2.2.15-4mdksmp
        URL: 
        Comment: About 9 interesting pages open (for further 
thought/reading).Using 'sidebar' - search. No choices seemed to be available via 
the pull down menu. Selected 'Customise' from sidebar tabselect ''search' select 
'preview'still no choice in pulldown menu.
         Detailed : http://cyclone/reports/incidenttemplate.cfm?bbid=27194118
         StackTrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=27194118
(Assignee)

Comment 25

17 years ago
lots of mandrake versions of linux showing up in jpatel's query.
I installed gtk/glib 1.2.7, could not get this to crash on rh6.2.
I don't even see any asserts.  Works on 1.2.8.

Off of the 081 radar, marking future for now.
We need someone to debug this on mandrake, if 1.2.8 solves
this problem as I am guessing, this could be a big red herring bug.
What config does Mandrake have?  We should start looking there.
Status: REOPENED → ASSIGNED
Target Milestone: mozilla0.8.1 → Future
(Assignee)

Updated

17 years ago
Keywords: helpwanted
Whiteboard: Needs Mandrake investigation. Possible gtk 1.2.7 bug, 1.2.8 may fix
(Assignee)

Comment 26

17 years ago
doron <doronr@gmx.net> reports that mandrake 7.1/gtk 1.2.8 works fine.
I'm tempted to mark this works-for-me, my best guess 
right now is mandrake got caught with gtk 1.2.7 bug of
some kind.  I'll leave this open for a while in case
anyone has other clues or hints.

Updated

17 years ago
Keywords: nsbeta1 → nsbeta1-

Comment 27

17 years ago
libgdk-1.2.so.0 - handle_key_release_event is no longer showing up on M09 or 
trunk crash reports.  Also, I'm not able to reproduce it, so I'm calling this 
fixed.  If someone else is getting it to happen, please reopen this report.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
v
Status: RESOLVED → VERIFIED
Crash Signature: [@ libgdk-1.2.so.0 - handle_key_release_event]
You need to log in before you can comment on or make changes to this bug.