Last Comment Bug 564214 - Add .<Emarat> to IDN whitelist
: Add .<Emarat> to IDN whitelist
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Networking: Domain Lists (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Gervase Markham [:gerv]
:
: Patrick McManus [:mcmanus]
Mentors:
http://هيئة-تنظيم-الاتصالات.امارات/
Depends on:
Blocks: IDN
  Show dependency treegraph
 
Reported: 2010-05-06 09:51 PDT by Neil Harris
Modified: 2010-08-07 12:57 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
.7-fixed
.11-fixed


Attachments
Patch v.1 (824 bytes, patch)
2010-06-24 03:15 PDT, Gervase Markham [:gerv]
christian: approval1.9.2.7+
christian: approval1.9.1.11+
Details | Diff | Splinter Review

Description Neil Harris 2010-05-06 09:51:34 PDT
ICANN have announced three new IDN TLDs: this bug is to track the entry for the United Arab Emirates.  

See  http://www.icann.org/en/announcements/announcement-05may10-en.htm  for details.
Comment 1 Gervase Markham [:gerv] 2010-05-08 01:31:50 PDT
We need to wait for them to contact us.

Gerv
Comment 2 Gervase Markham [:gerv] 2010-06-24 03:01:06 PDT
Zain Al Abdeen Baig writes:

Dear Gerv,

We have recently been delegated “.امارات” (xn—mgbaam7a8h) as one of the first IDN TLD to be accepted by ICANN (http://icann.org/en/announcements/announcement-05may10-en.htm) and the delegation in the root DNS servers has been conducted by IANA (http://www.iana.org/domains/root/db/xn--mgbaam7a8h.html).  Registration for websites have started and registrants now have live websites with their IDN.IDN “.امارات” domains.

Kindly find the allowed characters for the zone at http://aeda.ae/aeda/eng/emaratlngtb.php


... and later ...


Registry Home Page: http://aeda.ae
Policy Page: http://policy.aeda.ae
Language Table: http://aeda.ae/eng/emaratlngtb.php

Best Regards,

Zain Al Abdeen Baig
Senior System Administrator
Comment 3 Gervase Markham [:gerv] 2010-06-24 03:05:17 PDT
It looks like they are following the Arabic IDN RFC (5564). I'm just checking that this is the case but, assuming it is, this is fine and I'll prepare a patch.

Gerv
Comment 4 Gervase Markham [:gerv] 2010-06-24 03:15:48 PDT
Created attachment 453695 [details] [diff] [review]
Patch v.1
Comment 5 Gervase Markham [:gerv] 2010-06-24 03:28:55 PDT
The registry has confirmed they are following RFC 5564.
http://www.faqs.org/rfcs/rfc5564.html

Gerv
Comment 6 Gervase Markham [:gerv] 2010-06-24 03:33:22 PDT
Comment on attachment 453695 [details] [diff] [review]
Patch v.1

Requesting approval (we haven't quite officially agreed auto-approvals for these yet).

Gerv
Comment 7 Gervase Markham [:gerv] 2010-06-24 05:10:03 PDT
http://hg.mozilla.org/mozilla-central/rev/4d3aa712eab0

Gerv
Comment 8 christian 2010-06-24 13:40:02 PDT
Comment on attachment 453695 [details] [diff] [review]
Patch v.1

a=LegNeato for 1.9.2.6 and 1.9.1.11. Please land this on mozilla-1.9.2 default and mozilla-1.9.1 default.

Code freeze is this Friday @ 11:59 pm PST.
Comment 9 Gervase Markham [:gerv] 2010-06-25 01:30:38 PDT
1.9.1: http://hg.mozilla.org/releases/mozilla-1.9.1/rev/34814750d1df

Still waiting for 1.9.2 to go green.

Gerv
Comment 10 Gervase Markham [:gerv] 2010-06-25 09:13:54 PDT
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/cef80124331a

All done.

Gerv
Comment 11 Neil Harris 2010-06-26 05:37:51 PDT
Presumably this information also be added to the list at 

http://www.mozilla.org/projects/security/tld-idn-policy-list.html ?
Comment 12 Gervase Markham [:gerv] 2010-07-21 13:53:44 PDT
Neil: done.

Gerv

Note You need to log in before you can comment on or make changes to this bug.