Status

()

RESOLVED DUPLICATE of bug 520752
8 years ago
8 years ago

People

(Reporter: erwin.todts, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

Same as bug 520752
Sending a windows message with API SendMessage(...) opens a new FireFox Session

procedure TForm1.Button1Click(Sender: TObject);
var
  CopyDataStruct : TCopyDataStruct;
  sTemp: AnsiString;
begin
  sTemp := AnsiString(Edit1.Text);
  CopyDataStruct.dwData := 1973; //use it to identify the message contents
  CopyDataStruct.cbData := Length(sTemp) + 1;
  CopyDataStruct.lpData := PAnsiChar(sTemp);
  SendMessage(HWND_BROADCAST, WM_COPYDATA, MainInstance, Integer(@CopyDataStruct));
end;




Reproducible: Always

Actual Results:  
Firefox opens a new session

Expected Results:  
Do nothing

http://hg.mozilla.org/releases/mozilla-1.9.2/rev/28ef231a65a3
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 520752
You need to log in before you can comment on or make changes to this bug.