[d2d] Slow scrolling & image discoloration for very large image

RESOLVED DUPLICATE of bug 551350

Status

()

RESOLVED DUPLICATE of bug 551350
9 years ago
9 years ago

People

(Reporter: thewolf86, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:1.9.3a5pre) Gecko/20100506 Minefield/3.7a5pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:1.9.3a5pre) Gecko/20100506 Minefield/3.7a5pre

When the image at the URL attached is loaded the page scrolls very slowly and large part of the right hand side of the image is discolored - yellow in this case. Upon reloading the image it loads instantaneously (because it's cached I'm guessing) but Minefield becomes completely unresponsive. 

Reproducible: Always

Steps to Reproduce:
1. With Direct2D enabled go to the attache URL
2. Wait for it to load and scroll to the right to see the yellow discoloration
3. Reload page to reproduce unresponsiveness
Actual Results:  
Image is discolored and browser is slow/unresponsive

Expected Results:  
Image should show up without yellow discoloration at least, and browser should not be unresponsive 

Doesn't happen with Direct2D disabled. Always reproducible. Wish I had another test case.
Component: General → Graphics
Product: Firefox → Core
QA Contact: general → thebes
Version: unspecified → Trunk
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 551350
You need to log in before you can comment on or make changes to this bug.