Closed Bug 564979 Opened 12 years ago Closed 12 years ago

[FIX]Get rid of nsINode::GetSibling

Categories

(Core :: DOM: Core & HTML, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla1.9.3a5

People

(Reporter: bzbarsky, Assigned: bzbarsky)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

We can use GetNextSibling/GetPreviousSibling now.
Blocks: domperf
Depends on: 564432
Attached patch FixSplinter Review
Attachment #444590 - Flags: superreview?(jonas)
Attachment #444590 - Flags: review?(peterv)
Attachment #444590 - Flags: review?(peterv) → review+
Attachment #444590 - Flags: superreview?(jonas) → superreview+
Pushed http://hg.mozilla.org/mozilla-central/rev/90d627f2471e
Status: NEW → RESOLVED
Closed: 12 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a5
And backed out: http://hg.mozilla.org/mozilla-central/rev/c95e1d49bc79

The problem is that GetFirstChild is broken (and always has been!) for attribute nodes.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
> (and always has been!)

No, I lied.  It broke with bug 564432 part 2.
Depends on: 566416
I filed bug 566416 on fixing GetFirstChild.  That needs to be fixed before this can land.
Pushed http://hg.mozilla.org/mozilla-central/rev/ad277036ccbe
Status: REOPENED → RESOLVED
Closed: 12 years ago12 years ago
Resolution: --- → FIXED
Either this or bug 566416 gave us:

Improvement: Dromaeo (DOM) increase 3.27% on MacOSX 10.5.8 Firefox
Improvement: Dromaeo (DOM) increase 1.53% on Linux x64 Firefox
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.