Last Comment Bug 565022 - content inside <noscript> </noscript> is rendered in RSS html pages
: content inside <noscript> </noscript> is rendered in RSS html pages
Status: RESOLVED DUPLICATE of bug 662907
:
Product: MailNews Core
Classification: Components
Component: Feed Reader (show other bugs)
: unspecified
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 677555 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-11 03:05 PDT by RH
Modified: 2012-02-14 13:14 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description RH 2010-05-11 03:05:12 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 GTB7.0 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.9) Gecko/20100317 Thunderbird/3.0.4

I have a "News & Blogs" subscription to RSS feed and View->Feed Message Body As... set to "Web Page". Javascript in Thunderbird 3 is enabled. When viewing an HTML RSS article which contains a <noscript> xxx </noscript> part, the part xxx is rendered (i.e. displayed), even if Javascript is enabled.

I could reproduce the problem with almost any article on rss feed http://www.supermagnete.de/eng/projects_rss.xml, but now the folgs at supermagnete.de patched the problem on HTTP_USER_AGENT =~ Thunderbird/3, so you can't reproduce the problem with this page any longer. (

Reproducible: Always

Steps to Reproduce:
1. Subscribe to http://www.supermagnete.de/eng/projects_rss.xml

2. In Config Editor set general.useragent.extra.thunderbird to 'xx' and restart Thunderbird 3 (This is, because the folks at supermagnete.de now patched their html markup in case of an user agent like Thunderbird/3

3. Read article "Remove iron filings from magnets" (or almost any other article of this feed)
Actual Results:  
Every image on this page is rendered twice in Thunderbird 3.

Expected Results:  
Every image on this page should be displayed once only.
Comment 1 Ludovic Hirlimann [:Usul] 2010-05-24 04:42:30 PDT
Mark would this be related to the content policy ?
Comment 2 Mark Banner (:standard8) 2011-08-09 12:47:00 PDT
*** Bug 677555 has been marked as a duplicate of this bug. ***
Comment 3 alta88 2012-02-14 13:14:23 PST

*** This bug has been marked as a duplicate of bug 662907 ***

Note You need to log in before you can comment on or make changes to this bug.