Closed Bug 565027 Opened 10 years ago Closed 9 years ago

test_bug470377_3.js and others hang on Thunderbird builds on Mac (timeout after xpcshell/test_downloads/)

Categories

(Toolkit :: Add-ons Manager, defect, critical)

All
macOS
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: standard8, Unassigned)

References

Details

(Keywords: intermittent-failure, Whiteboard: [rewrite])

test_bug470377_3.js is hanging when we do builds of Thunderbird and run the xpcshell tests on Mac.

This is shown on the tinderboxes and when I do a debug build locally.

From what I can tell, the test completes successfully, and tries to finish, but then doesn't exit. Here's the end of a log from check-interactive:

TEST-PASS | /Users/moztest/comm/main/tb/mozilla/_tests/xpcshell/test_extensionmanager/xpcshell/test_bug470377_3.js | [anonymous : 120] true == true
TEST-PASS | /Users/moztest/comm/main/tb/mozilla/_tests/xpcshell/test_extensionmanager/xpcshell/test_bug470377_3.js | [anonymous : 121] [object Object] != null
TEST-PASS | /Users/moztest/comm/main/tb/mozilla/_tests/xpcshell/test_extensionmanager/xpcshell/test_bug470377_3.js | [anonymous : 122] true == true
TEST-INFO | (xpcshell/head.js) | test 1 finished
TEST-INFO | (xpcshell/head.js) | exiting test
*** LOG addons.xpi: shutdown

From what I can tell the Firefox builds don't do this.

As the do_test_finished() is called from a callback, I tried various things including doing a do_timeout(0, do_test_finished); which improved slightly from hanging all the time to only some of it, but still wasn't anywhere near consistently passing.

I can try debugging further if people have ideas of where to look.
This seems to be the same as bug 552957 which I saw happening in the early stages of the project branch but went away before I dug too much into it.

From what I remember the closest I got to tracking it down was this code:

http://mxr.mozilla.org/mozilla-central/source/testing/xpcshell/head.js#112

During the shutdown of the xpcshell test harness thr.hasPendingEvents would return true but then processNextEvent would block indefinitely.
FWIW this is now intermittent on Mac, but also seem to start at the very first of the extension manager tests. I'm going to try and do some tracking down.
Whiteboard: [rewrite] → [rewrite][orange]
Summary: test_bug470377_3.js and others hang on Thunderbird builds on Mac → test_bug470377_3.js and others hang on Thunderbird builds on Mac (timeout after xpcshell/test_downloads/)
Duplicate of this bug: 573476
I've not seen this recently. I'm assuming it has gone away.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
Blocks: 438871
Whiteboard: [rewrite][orange] → [rewrite]
You need to log in before you can comment on or make changes to this bug.