Need icons for new geolocation notification

RESOLVED FIXED in Firefox 4.0b2

Status

()

Firefox
Theme
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: Gavin, Assigned: shorlander)

Tracking

Trunk
Firefox 4.0b2
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: popupnotification)

Attachments

(3 attachments, 2 obsolete attachments)

Alex's mockups include a largish globe-like icon for the notification itself, and a smaller reticle-like icon for the location bar.
(Assignee)

Updated

8 years ago
Assignee: nobody → shorlander

Comment 1

8 years ago
Created attachment 453316 [details]
An example of a Geo icon in 64x64 as found on the InterWeb.

This is the icon that I have used in my themes.
Source:
http://kurage.kilo.jp/

Another good source of a world image is:
http://commons.wikimedia.org/wiki/File:Erioll_world_2.svg

And a rotating one:
http://gaialab.asu.edu/Jordan/
(Assignee)

Comment 2

8 years ago
Created attachment 455049 [details] [diff] [review]
Patch for New Geolocation Notifications Icons

This patch adds new notification icons for geolocation.

- Adds 64x64 geolocation panel icons for Windows, Mac and Linux
- New location bar glyph for Windows, Mac and Linux
- Removes the old Geo.png
- Match the -16, -64 naming convention
- Fixes the margin issue on OS X
Attachment #455049 - Flags: review?(dao)
(Assignee)

Comment 3

8 years ago
Created attachment 455050 [details]
Screenshot of new icons in use
Whiteboard: popupnotification
Comment on attachment 455049 [details] [diff] [review]
Patch for New Geolocation Notifications Icons

>+#geolocation {
>+  margin-left: -27px;
>+}

What's this?

We usually try to avoid globes with real land masses, and the crosshairs on the US seems particularly bad... Can we use the Firefox globe for this?
(Assignee)

Comment 5

8 years ago
(In reply to comment #4)
> (From update of attachment 455049 [details] [diff] [review])
> >+#geolocation {
> >+  margin-left: -27px;
> >+}
> 
> What's this?

To fix the huge left margin caused by using border image for the panels.


> We usually try to avoid globes with real land masses, and the crosshairs on the
> US seems particularly bad... Can we use the Firefox globe for this?

They are actually not real continents beyond a general location similarity that just happened to work out better in the composition.

Thanks!
(In reply to comment #5)
> > >+#geolocation {
> > >+  margin-left: -27px;
> > >+}
> > 
> > What's this?
> 
> To fix the huge left margin caused by using border image for the panels.

We need a more generic solution to this, as the same panel style is going to be used for other notifications. I'd prefer this to be taken care of in a separate bug.

> > We usually try to avoid globes with real land masses, and the crosshairs on the
> > US seems particularly bad... Can we use the Firefox globe for this?
> 
> They are actually not real continents beyond a general location similarity that
> just happened to work out better in the composition.

Even at a second and third glance I still seem to recognize North and South America. It's an icon, so it doesn't really matter that the borders aren't quite accurate, the rough shape counts.
(Assignee)

Comment 7

8 years ago
Created attachment 455316 [details] [diff] [review]
Patch for New Geolocation Notifications Icons 1.1

(In reply to comment #6)
> We need a more generic solution to this, as the same panel style is going to be
> used for other notifications. I'd prefer this to be taken care of in a separate
> bug.

Yeah I agree. Removed.

> Even at a second and third glance I still seem to recognize North and South
> America. It's an icon, so it doesn't really matter that the borders aren't
> quite accurate, the rough shape counts.

I tweaked them a little to try and mitigate that but in general I don't feel it is a problem and I feel comfortable with them as they are.

Thanks! :)
Attachment #455049 - Attachment is obsolete: true
Attachment #455049 - Flags: review?(dao)
(Assignee)

Comment 8

8 years ago
Created attachment 455319 [details]
Screenshot of new icons in use 1.1
Attachment #455050 - Attachment is obsolete: true
(Assignee)

Updated

8 years ago
Attachment #455316 - Flags: review?(dao)

Updated

8 years ago
Attachment #455316 - Flags: review?(dao) → review+

Updated

8 years ago
Keywords: checkin-needed
http://hg.mozilla.org/mozilla-central/rev/ffedf4255772
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.7b2

Updated

8 years ago
Blocks: 570004

Updated

8 years ago
Blocks: 573588

Updated

8 years ago
No longer blocks: 573588

Updated

8 years ago
Blocks: 573588

Updated

8 years ago
No longer blocks: 573588

Updated

8 years ago
Depends on: 581193
Duplicate of this bug: 601241

Updated

7 years ago
No longer depends on: 581193
You need to log in before you can comment on or make changes to this bug.