Cannot edit FIXED bugs when a blocker is open, when "noresolveonopenblockers" is on

RESOLVED FIXED in Bugzilla 3.6

Status

()

Bugzilla
Creating/Changing Bugs
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Graeme Coates, Assigned: Frédéric Buclin)

Tracking

({regression})

Bugzilla 3.6
regression
Bug Flags:
approval +
approval3.6 +
blocking3.6.1 +

Details

Attachments

(1 attachment)

812 bytes, patch
Max Kanat-Alexander
: review+
Details | Diff | Splinter Review
(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2 GTB7.0 (.NET CLR 3.5.30729)
Build Identifier: Bugzilla 3.6

Situation:

Bug 1 blocks Bug 2
Both are resolved, but subsequently Bug 1 is reopened.

At this point I cannot make any comment on Bug 2 due to the open blocking bug. If I choose to edit Bug 2 and remove the dependency on Bug 1, I get the Error: 

"Bug# 2  still has 1 unresolved dependency. Show Dependency Tree."

However, I can get to exactly the same point by going to Bug 1 and removing the "blocks" entry for bug 2. It seems a little strange that Bugzilla warns me I can't make a change to Bug 2 to remove the dependency because there is a dependency...




Reproducible: Always

Steps to Reproduce:
1. Setup one bug blocking another, and then resolve both.
2. Reopen the blocker.
3. Attempt to edit the blocked bug - not allowed (though actually, no reason why I shouldn't be able to add a comment here IMHO without a status change).
4. Attempt to remove dependency from blocked (resolved) bug - cannot remove dependency due to dependency!
Actual Results:  
Dependency doesn't allow user to remove dependency.

Expected Results:  
Should be able to remove only dependency from a bug that has only one open dependency.
(Assignee)

Comment 1

7 years ago
Yes, I can reproduce the issue. The noresolveonopenblockers parameter is only supposed to prevent resolving bugs, not preventing any other changes. Probably a regression.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking3.6.1+
Keywords: regression
Target Milestone: --- → Bugzilla 3.6
Version: unspecified → 3.6
(Assignee)

Comment 2

7 years ago
Created attachment 444903 [details] [diff] [review]
patch, v1

If the bug is already resolved as FIXED, do not prevent to edit it. No idea which bug regressed this, but I cannot reproduce in Bugzilla 3.4.
Assignee: create-and-change → LpSolit
Status: NEW → ASSIGNED
Attachment #444903 - Flags: review?(mkanat)
(Assignee)

Updated

7 years ago
Summary: Cannot remove dependency for fixed bug where blocker is reopened, but can remove block from reopened bug → Cannot edit FIXED bugs when a blocker is open, when "noresolveonopenblockers" is on

Comment 3

7 years ago
Comment on attachment 444903 [details] [diff] [review]
patch, v1

This looks good. :-)
Attachment #444903 - Flags: review?(mkanat) → review+

Updated

7 years ago
Flags: approval3.6+
Flags: approval+
(Assignee)

Comment 4

7 years ago
Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/trunk/
modified Bugzilla/Bug.pm
Committed revision 7161.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/3.6/
modified Bugzilla/Bug.pm
Committed revision 7095.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.