Web sites should not be able to steal focus when in chrome

RESOLVED DUPLICATE of bug 125282

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 125282
8 years ago
8 years ago

People

(Reporter: John Wayne Hill (UX Intern), Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
(Note: this is filed as part of the “Paper Cut” bugs — we assume that there may be multiple existing bugs on this. Please make them block this bug, and we will de-dupe if they are indeed exactly the same. Thanks!)

To reproduce:
1. Start Firefox with a slow loading page
2. start typing in the chrome search while the page is loading
3. webpage steals focus while typing

Recommendation:
- Disallow pages to steal focus whenever a user is in the chrome.
- If there's been any keyboard input or mouse scrolling while the page is still loading, don't allow onload=setfocus()
- When focused with Cmd-L, if you hit Esc, you should be back in the web page
(Reporter)

Updated

8 years ago
Depends on: 140346
No longer depends on: 140346
See Also: → bug 140346
I think this is a dupe of bug 125282, which was fixed on the trunk.
Marked as duplicate, I believe this is the same thing too. Will re-open if I still see this behavior. Thanks, Daõ!
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 125282
Dead key hit the wrong character, I meant:

Thanks, Dão!
You need to log in before you can comment on or make changes to this bug.