Last Comment Bug 565682 - Support dropping xpi/jar files on the add-ons manager
: Support dropping xpi/jar files on the add-ons manager
Status: VERIFIED FIXED
[in-litmus-bug-week][rewrite]
:
Product: Toolkit
Classification: Components
Component: Add-ons Manager (show other bugs)
: Trunk
: All All
: P1 normal with 4 votes (vote)
: mozilla2.0b1
Assigned To: Dave Townsend [:mossop]
:
Mentors:
: 569151 (view as bug list)
Depends on:
Blocks: 550048 567640
  Show dependency treegraph
 
Reported: 2010-05-13 09:38 PDT by Dave Townsend [:mossop]
Modified: 2010-09-17 18:50 PDT (History)
18 users (show)
dtownsend: in‑testsuite+
hskupin: in‑litmus+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
final+


Attachments
patch rev 1 (17.08 KB, patch)
2010-06-15 13:59 PDT, Dave Townsend [:mossop]
bmcbride: review+
Details | Diff | Splinter Review

Description Dave Townsend [:mossop] 2010-05-13 09:38:10 PDT
In Firefox this just magically works because we are displaying in a content browser, but for apps that want to display the add-ons manager in its own window it won't. The solution is to add drop support for files to the add-ons manager UI.
Comment 1 Pardal Freudenthal (:ShareBird) 2010-05-18 21:08:47 PDT
Most of themes at AMO are packaged as .jar files, so the add-ons manager should also support dropping .jar files.
Comment 2 Dave Garrett 2010-05-30 13:00:27 PDT
*** Bug 569151 has been marked as a duplicate of this bug. ***
Comment 3 Dave Townsend [:mossop] 2010-06-11 16:37:08 PDT
Patch in progress.
Comment 4 Dave Townsend [:mossop] 2010-06-11 17:14:00 PDT
I'm going to be able to automate some of the testing here, but we can't properly simulate a drag of files from outside the app in the test suites so we should make sure there is litmus coverage here.
Comment 5 Dave Townsend [:mossop] 2010-06-15 13:59:16 PDT
Created attachment 451365 [details] [diff] [review]
patch rev 1

This adds a drop handler to the add-ons manager window and verifies that dropping files and urls on it will start installs.
Comment 6 Blair McBride [:Unfocused] (mostly unavailable, needinfo open, reviews not) 2010-06-15 21:15:53 PDT
Comment on attachment 451365 [details] [diff] [review]
patch rev 1

I'm unfamiliar with the text/uri-list mimetype - it *sounds* like each item of this mimetype would be a list of URIs, but the code assumes its one URI per item. I'm guessing its converted to multiple items before we get to it. But if not, you'll need to handle that.

Wish we could avoid the install confirmation dialog, since its an explicit action. But I guess that needs to stay :\
Comment 7 Dave Townsend [:mossop] 2010-06-15 21:19:37 PDT
(In reply to comment #6)
> (From update of attachment 451365 [details] [diff] [review])
> I'm unfamiliar with the text/uri-list mimetype - it *sounds* like each item of
> this mimetype would be a list of URIs, but the code assumes its one URI per
> item. I'm guessing its converted to multiple items before we get to it. But if
> not, you'll need to handle that.

Should have mentioned, most of the handling of the different types is just copied from the old code and we never heard any complaints about it so I'm guessing it is correct enough.

> Wish we could avoid the install confirmation dialog, since its an explicit
> action. But I guess that needs to stay :\

I think we still need the conformation, just so users know what they're getting from urls etc., however we have a bug somewhere on ditching the countdown timer in that case which is probably a good idea.
Comment 8 Dave Townsend [:mossop] 2010-06-17 15:51:42 PDT
Landed: http://hg.mozilla.org/mozilla-central/rev/eb16fbc5530a.

As mentioned this is testing only as far as injecting pretend drag events to the UI. We should have some real manual testing of this too.
Comment 9 Henrik Skupin (:whimboo) 2010-06-24 07:27:48 PDT
Verified fixed on trunk with builds on all platforms like Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a6pre) Gecko/20100624 Minefield/3.7a6pre
Comment 10 Henrik Skupin (:whimboo) 2010-09-17 18:42:54 PDT
Test has been updated on Litmus:
https://litmus.mozilla.org/show_test.cgi?id=10306

Dave, do we have plans to allow D&D of .jar files into the browser? Right now that only works inside the Add-ons Manager.
Comment 11 Dave Townsend [:mossop] 2010-09-17 18:50:10 PDT
(In reply to comment #10)
> Test has been updated on Litmus:
> https://litmus.mozilla.org/show_test.cgi?id=10306
> 
> Dave, do we have plans to allow D&D of .jar files into the browser? Right now
> that only works inside the Add-ons Manager.

We never have before because jar files can be all sorts of things.

Note You need to log in before you can comment on or make changes to this bug.