expand threshold for correlation reports from 2 to 3 top releases

RESOLVED FIXED

Status

RESOLVED FIXED
9 years ago
7 years ago

People

(Reporter: chofmann, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
when we start doing release candidate builds we often loose the plugin addon correlation reports because the release doesn't have enough users/crashes to qualify for getting the reports run.

the script currently looks something like this

select version, count(*) as counts from reports_${WEEK} 
 where completed_datetime < NOW() 
  and completed_datetime > (NOW() - interval '24 hours') 
  and product = '${I}' 
  and version like '%b%' group by version order by counts desc limit 2

looking at the current breakdown for firefox the top crashing versions are 3.6.3 and 3.5.9 so only those releases qualify for reporting

251158  0.685711        3.6.3
33033   0.0901866       3.5.9
-----
20169   0.0550653       3.6.4
13383   0.0365382       3.6
11062   0.0302014       3.0.19
3820    0.0104294       3.6.2
2312    0.00631221      3.7a5pre
1718    0.00469048      3.5.5
1680    0.00458673      3.5.7
1628    0.00444476      4.0a1pre

If we expand to the top 3 releases then 3.6.4 which is in "release candidate mode" would be under the threshold and reports would get produced.

This means a bit more diskspace but it seems a good trade off for being able to track correlations in the last builds before they get shipped to a lot of users.

bug 295514 and a few others are bugs we are looking at where correlations would be valuable in figure out blocking decisions.
Done.  You should see the top three versions in tomorrows output.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
Component: Socorro → General
Product: Webtools → Socorro
You need to log in before you can comment on or make changes to this bug.