Closed Bug 566212 Opened 12 years ago Closed 12 years ago

closing Firefox by shutting down Ubuntu makes session be restored

Categories

(Firefox :: Session Restore, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 557601

People

(Reporter: pedbessa, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pt-BR; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 Glue/4.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; pt-BR; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 Glue/4.5 (.NET CLR 3.5.30729)

First of all, I set: on Firefox start, open start page, about:home as the start page and session to be restored after a crash.

If I have Firefox opened (visiting many sites in many tabs), but instead of closing Firefox directly, I shut down Ubuntu, when I start Ubuntu and open Firefox, the session is restored with all those sites and all those tabs.

Reproducible: Always

Steps to Reproduce:
1. set on Firefox start, open start page
2. set about:home as the start page
3. set session to be restored after a crash
4. open 2 tabs
5. go to 2 sites (1 site in each tab), but don't close the 2 tabs
6. click the button on top-right corner to shut down / turn off
7. select Shut Down / Turn Off
8. start Ubuntu
9. open Firefox
Actual Results:  
The 2 tabs with the 2 sites are opened automatically.

Expected Results:  
Firefox opens about:home.
So my best guess is that there's a problem with Firefox handling OS shutdown messages. And as you might have guessed, Firefox thinks it has crashed and so it resumes your session.

I'm going to dupe this against bug 557601, but I know I've seen this problem in at least 1 other bug. I don't think it's actually a session restore bug, but it appears to manifest it that way.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 557601
This bug doesn't appear when I click "My Bugs".
(In reply to comment #2)
> This bug doesn't appear when I click "My Bugs".

"My Bugs" is a built in saved search for OPEN bugs you are involved with. This bug is closed so it won't show up.
Workaround:

install the gui:config addon
go Minefield -> Preferences -> Advanced Settings... -> Session Restore
uncheck Restore Session After Crash
uncheck Enable Session Restore
Comment 4 didn't work.

I'm trying unchecking Firefox Sync's history and tabs as workaround.
Comment 5 didn't work.

I'm trying to check, then uncheck "Automatically remember apps running on session end" in Ubuntu -> System -> Preferences -> Session Apps as workaround.
Comment 6 didn't work.
You need to log in before you can comment on or make changes to this bug.