problems with plugins and helper apps.

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
P3
normal
RESOLVED WORKSFORME
18 years ago
17 years ago

People

(Reporter: R.K.Aa., Assigned: av (gone))

Tracking

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
2000101406

Mozilla still doesn't see the realplayer plugin.

i have copied raclass.zip and rpnp.so to:
/usr/lib/netscape/plugins
/usr/lib/mozilla/plugins
~/.mozilla/plugins
~/.netscape/plugins

I have added all locations of the rpnp.so occurances and realplay to $PATH
I have used "install mimetypes" from Realplayer Help menu, both as root and
user. Link to rpnphelper installed in /usr/bin.
No go. Mozilla does not see the plugin.

I changed the setup in prefs/helper apps to read rpnphelper for the filetypes i
manually had to put in there (what a chore.) (rpnphelper also being in $PATH)

Still no go. about:plugins doesn't show a thing about realplayer.
Sites that provide realplayer files tells me i don't have the plugin installed.

If i change it to be used as an application instead, mozilla still tells me that
realplayer plugin isn't installed, and it will not spawn realplayer as an
application.

Changing back to "handled by browser": still no go.

I copied every single module i found regarding rp to mozilla/plugins
No go.

Needless to say, the same realplayer7 install starts and runs just fine from
commandline, and it plays just fine as a plugin (!!) in NC4.75.

Mozilla doesn't recognize a single filetype for realplayer - not automatically,
and not if i add it as a helper application in prefs.
Obviously neither .mailcap nor .mime.types are read in from anywhere.
(They exist in homedir, /usr/lib/netscape/ and i copied them to
/usr/local/mozilla/ and /usr/local/mozilla/defaults


Apart from this: Every time i click a radiobutton in prefs/helper-apps/edit
dialog, error appears in console:

JavaScript error:
 line 2: this.selectedItem has no properties

I'm running out of ideas here. Is there some release note about how to make this
work in mozilla?
Do i have to manually create or edit some .rdf file to make it all work?

It might be worth noting that the installtaion packages contain NO file named
mimetype.xpt, but perhaps these
are packed in jar now? Mentioning this because it was the problem in bug 45689,
but that was labeled as an NT bug.

While i used the old tar.gz files that i only unpacked and ran, the file
mimetype.xpt used to be in package/components/

I had to stop downloading those tar.gz files when they suddenly grew with 3 MB.
I'm on a modem. So now i use SEA or installed builds. And in package/components
in an installer or SEA build, there are only these xpt related files:

./components/browser.xpt
./components/mail.xpt
./components/xptitemp.dat
./components/qfaservices.xpt
./components/xpti.dat
(Reporter)

Comment 1

18 years ago
CC mscott since he's used to my nagging.
(btw - There is a Windows bug on a related matter also, in bug 54437.)
(Reporter)

Comment 2

18 years ago
Perhaps a clue to some of this mess: In bug 56662 a user observes that $PATH
isn't honored, and helper apps (in this case xmms) has to be filled in with full
pathstatement in prefs.
(Reporter)

Comment 3

18 years ago
Also see bug 56760.
Not a Netscape 6 RTM blocker. FUTURE. This bug has been marked Future because
the Netscape engineer it is assigned to is overburdened.
Target Milestone: --- → Future

Updated

18 years ago
Keywords: 4xp, realplayer

Comment 5

18 years ago
Realplayer does not work on standard Linux installations because of this bug.
People will not want to use a Browser that does not work with multimedia
plugins. nominating for further consideration.

Note: Real has never worked, as a plugin for Netscape 6 builds or Mozilla builds
on any of my RedHat machines -- either 6 or 7.
Keywords: mozilla0.9, nsbeta1

Comment 6

18 years ago
Most people have to run a gcc 2.95 build in order to get the real player plugin
working.
This should probably be marked a dup of bug 56464.
(Reporter)

Comment 7

17 years ago
in own builds with gcc2.96 realpayer works. I also noticed that it works in
Netscape 6.1. What might remain is thoroughly covered in other bugs. WFM.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.