Bad wording when getting any plugin

VERIFIED FIXED in mozilla0.9

Status

()

P3
trivial
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: morse, Assigned: peterlubczynski-bugs)

Tracking

Trunk
mozilla0.9
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
The first time you go to a page that uses java, you get a message about fetching 
the java plugin.  That message says:

   The smart update feature makes it easy to install new plugins.  To take
   advantage of SmartUpdate, you must enable java, javascript,
   and autoinstall in the advanced panel of the preferences, then click the
   plugin icon on the page.

But the advanced pref panel does not have have a checkbox for autoinstall (it 
does have checkboxes for java and javascript).  Rather the autoinstall checkbox 
is under the "Software Installation" subpanel of the advanced panel.  
Furthermore, it is never referred to as autoinstall on this subpanel.

Comment 1

18 years ago
Changing module to OJI
Assignee: idk → drapeau
Component: Java-Implemented Plugins → OJI

Comment 2

18 years ago
Re-assigning to module owner (Ed Burns), and copying fixer of bug 48483, since
this might be relevant.
Assignee: drapeau → edburns

Comment 3

18 years ago
This is probably a XUL problem.  Re-assigning.
Assignee: edburns → trudelle
Component: OJI → XP Toolkit/Widgets: XUL
QA Contact: geetha.vaidyanaathan → jrgm

Updated

18 years ago
Assignee: trudelle → av
Component: XP Toolkit/Widgets: XUL → Plug-ins
QA Contact: jrgm → shrir

Comment 4

18 years ago
That'd be a plugin resource files ... ->plugins/av/shrir

Comment 5

18 years ago
The fix would be trivial. If anybody comes up with the correct wording...
Status: NEW → ASSIGNED
(Assignee)

Comment 6

18 years ago
*** Bug 59838 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 7

18 years ago
This is just like the other one I had. We should get the wording right since 
it's easy.

Eric, what would you like it to say?
Assignee: av → peterlubczynski
Severity: normal → trivial
Status: ASSIGNED → NEW
Target Milestone: --- → mozilla0.9

Comment 8

18 years ago
I'm adding Steve Rudman to the bug.  Steve, is it possible that someone from
your team can suggest wording?
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 9

18 years ago
Chris,

What do you think this should say?

See http://bugzilla.mozilla.org/showattachment.cgi?attach_id=19628
for current display.

Comment 10

18 years ago
There is no need to introduce the term "SmartUpdate" here, since the term isn't
used in the UI or in the Help. And I assume the users are taken directly to the
plug-ins page and that they bypass the SmartUpdate main page. 

The prefs mentioned are set by default, so we don't want to obligate users to
cancel out of this modal dialog just to check prefs that are probably enabled.
But we can leave text in the dialog that might help if they run into trouble.
Suggested rewording for the last paragraph of the dialog:

"To retrieve the plug-in now, click the Get the Plug-in button and then select
the plug-in you need from the page that appears. If you have trouble installing
the plug-in, make sure that Java and JavaScript are enabled in Advanced
preferences, and that software installation is enabled (in the Software
Installation category under Advanced)."

You can delete "What would you like to do?"
(Assignee)

Comment 11

18 years ago
Will the localization freeze effect this bug? If so, this needs to be done 
ASAP. 

Frank, do you know?
Summary: Bad wording when getting java plugin → Bad wording when getting any plugin

Comment 12

18 years ago
Moving to mozilla0.8.1
Target Milestone: mozilla0.9 → mozilla0.8.1
(Assignee)

Comment 13

18 years ago
Created attachment 26638 [details] [diff] [review]
windows patch to npnul32.res
(Assignee)

Comment 14

18 years ago
This needs to be changed on all platforms to be correct.
Keywords: patch
OS: Windows NT → All
Hardware: PC → All

Comment 15

18 years ago
ar=av
(Assignee)

Comment 16

18 years ago
Marc, can I get a sr= on this one too?

Comment 17

18 years ago
sr=attinasi for the Windows patch. What about the other platforms?
(Assignee)

Comment 18

18 years ago
Other platforms coming soon as I learn their resource editors.

We should have an XP solution for the NULL plugin.
(Assignee)

Updated

18 years ago
Target Milestone: mozilla0.8.1 → mozilla0.9
(Assignee)

Comment 19

18 years ago
Other platforms Default Plugins' don't have so much text. Their message seems
fine to me as is. This is only Windows.
OS: All → Windows 2000
Hardware: All → PC
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 20

18 years ago
Patch checked in. 


===> new revision: 1.4; previous revision: 1.3

Comment 21

18 years ago
verified that new wordings show up properly now in the "download java plugin 
dialog. (0416)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.