Status

()

enhancement
RESOLVED WONTFIX
9 years ago
a year ago

People

(Reporter: kinger, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rewrite])

Reporter

Description

9 years ago
Maybe I'm just used to it elsewhere, but having to hit enter in the search field to find add-ons seems unintuitive. It would be great if filtering happened as-you-type.
Once we add support for searching AMO as well, doing a lookup as you type could end up pounding on their servers more than we'd like
Keywords: uiwanted
Blocks: 550048
Severity: normal → enhancement
Hardware: x86 → All
Whiteboard: [rewrite]
We plan on adding find-as-you-type support to both AMO and our search plugin soon, which should cache a lot of the typed stems. I don't think it'd be a problem for us.
We're not afraid of your feeble traffic!


Do you have estimates on how much traffic this will generate?  I think we'll be ok, but if we send a 503 response, you should respect our retry-after header.
(In reply to comment #3)
> Do you have estimates on how much traffic this will generate?  I think we'll be
> ok, but if we send a 503 response, you should respect our retry-after header.

Not really, I could guesstimate at maybe 2-3 times more traffic depending on how slow users type things in but really we'd just need to try it to see. Backoff isn't supported right now but probably wouldn't be too difficult to fix.
Assignee: nobody → jboriss
Keywords: uiwanted
Assignee: jboriss → mdeboer
Depends on: 712514
Status: NEW → ASSIGNED
Assignee: mdeboer → nobody
Status: ASSIGNED → NEW

Comment 5

a year ago
AMO does this and we bounce the search over there now.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
Duplicate of this bug: 1431312

Comment 7

a year ago
What about search within My Add-ons?
Flags: needinfo?(mdeboer)

Updated

a year ago
Flags: needinfo?(ddurst)

Comment 8

a year ago
That feature to search within your own add-ons has been removed in bug 1263313, the vast majority of users have less than 4 extensions and this feature cost too much to maintain for it's value.

When addons.mozilla.org re-implements mozAddonManager the site will indicate if you've got the add-on installed. To follow that bug see:

https://github.com/mozilla/addons-frontend/issues/3954

If you'd like to search within your own add-ons, you can write a WebExtension using the management.getAll API documented here:

https://developer.mozilla.org/en-US/Add-ons/WebExtensions/API/management/getAll
Flags: needinfo?(mdeboer)
Flags: needinfo?(ddurst)
You need to log in before you can comment on or make changes to this bug.