Cannot log in to Bugzilla

VERIFIED INVALID

Status

()

P3
normal
VERIFIED INVALID
18 years ago
18 years ago

People

(Reporter: stephe, Assigned: rods)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
When I try to log in to Bugzilla using Mozilla, I get the error:

"The e-mail address you entered (stephe@wenet.net) didn't match our minimal
syntax checking for a legal email address. A legal address must contain exactly
one '@', and at least one '.' after the @, and may not contain any commas or
spaces."

My email address in the URL looks like "Bugzilla_login=stephe%40wenet%A9net".

If I use NN4 to log in, it works ok, and my email address in the URL looks like
"Bugzilla_login=stephe%40wenet.net".  I would have to say that the %A9 that
Mozilla uses is wrong.

To reproduce, log out of Bugzilla and try to enter a new bug.

Tested with Mozilla 101406 on Linux.

Comment 1

18 years ago
WFM 2000101409 linux

Comment 2

18 years ago
works for me too, linux 2000101015 - marking invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
reaper: if it works for you, you mark it WORKSFORME, not INVALID.

This has actually been seen by several people, although nobody can work out why.
(Reporter)

Comment 4

18 years ago
I am reopening this bug since it is still happening to me with Mozilla 101506 on
Linux.  I am not making this stuff up, and I think it is an abuse of Bugzilla to
so carelessly mark a bug INVALID.  I could not even to use Mozilla to comment on
this bug since I cannot log in.  I had to resort to NN4.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 5

18 years ago
hmm ... my bad, I thought this was related to the the faulty builds the other
day that didn't allow ANYONE to log into bugzilla. That's why I marked it
INVALID - lesson learned for me .... still, a lot of people are not seeing this
bug, so if you're around on tuesday, let's meet on #mozillazine, grab some linux
folks, and see if we can make this one go away ....

(Reporter)

Comment 6

18 years ago
Sigh.  Now I find that this is an invalid bug after all.  It turns out the
problem was my character coding was set to Armenian which is strange since I
never set that myself.  What is even stranger is that Mozilla would keep
switching back to Armenian no matter how many times I chose Western and my
default character code in Preferences is Western.

In any case, I created a new profile, and the problem went away.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → INVALID

Comment 7

18 years ago
verifying as for reporter's coments
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.