Closed Bug 566698 Opened 11 years ago Closed 11 years ago

Make PixelStorei reject invalid param values

Categories

(Core :: Canvas: WebGL, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 571027

People

(Reporter: bjacob, Assigned: bjacob)

Details

Attachments

(1 file, 3 obsolete files)

Assignee: nobody → bjacob
Status: NEW → ASSIGNED
Attachment #446039 - Flags: review?(vladimir)
oops, previous patch was wrong file. the gtk filechooser dialog is massively broken over here.
Attachment #446039 - Attachment is obsolete: true
Attachment #446040 - Flags: review?(vladimir)
Attachment #446039 - Flags: review?(vladimir)
Also, it looks like the patch needs to be updated to use some ErrorInvalid* function.
Keywords: checkin-needed
Updated to return the right error.

carried r+ from previous version.
Attachment #446040 - Attachment is obsolete: true
Attachment #448566 - Flags: review+
aargh, typo, give me a minute...
(In reply to comment #3)
> This needs a test.

Yep, working on integrating the WebGL test suite this week -- there's a test in there for this.  Marking all these things as in-testsuite? for verification once we get that in.
Flags: in-testsuite?
This time it should be good!
Attachment #448566 - Attachment is obsolete: true
Attachment #448571 - Flags: review?(vladimir)
If you are asking for review for this updated patch, probably not ready for checkin-needed.
Keywords: checkin-needed
Marking as duplicate as an updated patch is present in bug 571027.
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 571027
You need to log in before you can comment on or make changes to this bug.