vpnd takes 100% of CPU and 3.6 GB RAM on cb-xserve04

RESOLVED FIXED

Status

Camino Graveyard
General
--
major
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Smokey Ardisson (offline for a while; not following bugs - do not email), Assigned: ss)

Tracking

({perf})

Details

All three builds on cb-xserve04 had a sudden, inexplicable 100ms jump in Ts at about 10am this morning, with no checkins or anything for any of them.

This afternoon when I logged on, I noticed that vpnd was taking 100±% of CPU, which is not normally the case.  Killing vpnd was not effective, as it just restarted and took over again.  Restarting the tinderbox was also not effective.

From further watching, I noticed vpnd starts, takes 100% of CPU, climbs up to ~3.6 GB of RAM, quits, restarts, and begins all over again.

So, something's wrong with vpnd on this box.  Is vpnd required for ssh or VNC access to the box (I don't think so, because killing it manually didn't disconnect me, and its auto-restarting after it had consumed 3.6± GB of RAM also didn't disconnect me)?  If not, can we just turn it off?

I can't be certain that it's the cause of the Ts regression, but I hadn't ever seen it doing that in Activity Monitor when I've looked before.
(Assignee)

Comment 1

8 years ago
It can be turned off. I was testing something a while ago and thought I disabled it again... apparently not.
(In reply to comment #1)
> It can be turned off. I was testing something a while ago and thought I
> disabled it again... apparently not.

Please do.  I poked around some more tonight for the weekly restart and was unable to determine how to disable it.
Assignee: nobody → samuel.sidler
(Assignee)

Comment 3

8 years ago
Me either.

But after poking around a lot more and restarting quite a few times, I finally removed (well, moved) /System/Library/LaunchDaemons/com.apple.ppp.l2tp.plist and it stopped vpnd. Well, after a restart anyway. Server Admin and Server Preferences both show VPN as being disabled.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
This appears to have fixed vpnd chewing CPU and RAM, but not the Ts regression :( I moved tracking the Ts regression into bug 567813, since they're apparently unconnected.
Summary: vpnd takes 100% of CPU and 3.6 GB RAM on cb-xserve04 / 100ms Ts regression on all builds on ~10am 18 May → vpnd takes 100% of CPU and 3.6 GB RAM on cb-xserve04
You need to log in before you can comment on or make changes to this bug.