Closed Bug 566987 Opened 12 years ago Closed 11 years ago

Prince of Persia Film Trailer shows artifacts when playing it back with video tag and webm!

Categories

(Core :: Audio/Video, defect)

x86
Linux
defect
Not set
minor

Tracking

()

RESOLVED FIXED

People

(Reporter: no-reply-address-of-florian, Unassigned)

References

()

Details

Attachments

(2 files, 1 obsolete file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a4webm) Gecko/20100518 MozillaDeveloperPreview/3.7a4webm
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a4webm) Gecko/20100518 MozillaDeveloperPreview/3.7a4webm

I noticed some artifacts in the prince of persia film trailer at second 23. They don't appear if I playback the video using flash but do occur if I watch the video encoded as webm.

Reproducible: Always
I uploaded the wrong file as attachment 446354 [details].
Attachment #446354 - Attachment is obsolete: true
I see this in Firefox (there are artifacts earlier in the panning scene, too) but not in my slightly old WebM-enabled Chromium build.
Status: UNCONFIRMED → NEW
Ever confirmed: true
So, this is caused by Tim's robustness patch (mv-bounds-check.patch) that we've applied to our copy of the decoder.  With the patch reverted the video plays without artifacts.
I posted a modified version of the patch which fixes this in the short term, but is not really a suitable long-term solution (as it relies on current encoder behavior and would do ugly things to the format if standardized) to the following thread: https://groups.google.com/a/webmproject.org/group/codec-devel/browse_thread/thread/ff90bd82d0369b96#

The discussion there over the correct long-term solution is ongoing.
Depends on: 566247
We've included Tim's patch in the WebM landing, in bug 566247.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.