Last Comment Bug 567013 - Please remove dead code interface: nsIBaseStream
: Please remove dead code interface: nsIBaseStream
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: unspecified
: All All
: -- trivial (vote)
: mozilla8
Assigned To: David Zbarsky (:dzbarsky)
:
Mentors:
http://mxr.mozilla.org/mozilla1.9.1/s...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-19 16:06 PDT by Alex Vincent [:WeirdAl]
Modified: 2011-08-12 13:45 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (4.47 KB, patch)
2011-08-08 17:39 PDT, David Zbarsky (:dzbarsky)
no flags Details | Diff | Splinter Review
Patch (4.53 KB, patch)
2011-08-08 17:43 PDT, David Zbarsky (:dzbarsky)
no flags Details | Diff | Splinter Review
Patch that actually compiles (4.74 KB, patch)
2011-08-08 17:58 PDT, David Zbarsky (:dzbarsky)
khuey: review+
Details | Diff | Splinter Review
Patch r=khuey (4.75 KB, patch)
2011-08-09 12:28 PDT, David Zbarsky (:dzbarsky)
Ms2ger: checkin+
Details | Diff | Splinter Review

Description Alex Vincent [:WeirdAl] 2010-05-19 16:06:13 PDT

    
Comment 1 David Zbarsky (:dzbarsky) 2011-08-08 17:39:27 PDT
Created attachment 551639 [details] [diff] [review]
Patch
Comment 2 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-08-08 17:42:31 PDT
Does this compile?  It looks like nsScriptableInputStream::Close is used ...
Comment 3 David Zbarsky (:dzbarsky) 2011-08-08 17:43:07 PDT
Created attachment 551642 [details] [diff] [review]
Patch
Comment 4 David Zbarsky (:dzbarsky) 2011-08-08 17:58:37 PDT
Created attachment 551644 [details] [diff] [review]
Patch that actually compiles

Gah, the code was lying.
Comment 5 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-08-09 06:41:33 PDT
Comment on attachment 551644 [details] [diff] [review]
Patch that actually compiles

I'm not really a peer, but this is easy enough.

r=me
Comment 6 David Zbarsky (:dzbarsky) 2011-08-09 12:28:14 PDT
Created attachment 551854 [details] [diff] [review]
Patch r=khuey
Comment 7 Justin Wood (:Callek) (Away until Aug 29) 2011-08-10 01:22:14 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/863ba598a27b

Note You need to log in before you can comment on or make changes to this bug.